Error installing HA on Green

So just received the HA Green. After plugging in and powering on, I saw that the switchport was disabled, so the Green didn’t have internet. Enabled the port, rebooted Green and now it shows the following:

[supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec
[supervisor.docker.interface] Updating image to
[supervisor.docker.interface] Downloading docker image with tag 2023.11.2.

[supervisor.docker.interface] Can't install 404 Client Error for http+docker://localhost/v1.43/images/ Not Found ("No such image:")

Disabled my AdGuard Home so there’s nothing blocked. connects to Github in my browser, so no issue there. Seen one topic where it may be a space issue, but the Green is new so I figured that hardly can be the problemen. But the information on the internet is hard to find, so I’m hoping someone here can help me further.

Same problem here. No solution found until yet. I also tried to contact support. I will update this post, when I receive an appropriate answer or solution.

Unfortunately, I feel the same way. I have connected the new Home Assistant Green to the power supply and the network. Now the device is also stuck in this endless loop.
I have no idea how to get out of it, but the device is currently expensive electronic waste for me :frowning:

After beeing frustrated for a while I did a factory reset.

After the reset, my device rebooted and was able to boot up in this way that I can now start configuring the system.


I had the same issue with my new-in-box Home Assistant Green.

Apparently, it downloads its docker image on the first startup, and if the power goes out during that, the corrupted downloaded image is corrupt and it can’t figure out how to recover.

I needed to unplug it to hook it up to a screen with HDMI, in order to determine the MAC address so I could whitelist the device with my apartment network. When I finally got the device showing in the browser, I had the setup error.

I didn’t want to flash an SD card to reset a brand new device, so first I tried these steps:

Except I used the local console, typing login and entering the commands there. Essentially, stopping docker, deleting its files, rebooting, then running supervisor repair.

Now I can connect and I finally see “Preparing Home Assistant” and then “Welcome!” Phew.

Hope this helps anyone with a brand new Home Assistant Green which fails out of the box.

Any luck? Stuck with same issue

Did you try my solution?

I greener to HA than the cover of my new HA Green Box. I went to install HA Server Green today, and had error using the URL provided in the setup documentation (http://homeassistant.local:8123). I was quickly defeated, as I thought this was supposed to be plug and play.

After a little reading, I ended up (1) logging into my router, (2) looking at the devices connected, (3) found the IP Address for the homeassistant device (4) and lastly entered http://IPADDRESSOFDEVICE:8123. This worked and I was able to get my HA Green Server up and running. I hope this helps other greenies out there. Cheers.

mDNS relies heavily on your local network setup and the compatibility of your router and other network hardware to function correctly. Some routers might not support mDNS, or it may be disabled.

Using IP address and port is always going to be one less layer and more direct. This isn’t really specific to the Green and you see this all over the community as new users set up servers for the first time in their network.

The convenience of using a host name is nice but always try the ip address (and port) when troubleshooting.