ERROR (MainThread) [homeassistant.components.updater]

2020-02-28 15:51:51 ERROR (MainThread) [homeassistant.components.updater] Could not contact Home Assistant Update to check for updates
2020-02-28 15:51:51 ERROR (MainThread) [homeassistant.components.updater] Error fetching Home Assistant update data:

What are these errors??? Thank you

1 Like

I am unsure what the errors are, but I get the same ones

Hi Guys, I hate to add onto this but I have received the same errors, “Error fetching Home Assistant update data:” and “Could not contact Home Assistant Update to check for updates”. I am connected to the internet and I do not have anything blocked. I can access my instance remotely and through Nuba Casa.

Same issue here, checked and nothing is being blocked.
I suppose time will tell if an update comes out and we dont get notified in HA.

I’m having this trouble too.

Any updates on this? Happening to me too.

Got also these error messaging since several days. Tried to turn-off the updater as entity but that did not resolve the problem. Lookiing forward to the solution of this error.

Same for me, switching the updater off then on didn’t help.

Same error experienced here after upgrade to Home Assistant 0.106.5 on Pi 3b.

2020-03-05 13:50:34 ERROR (MainThread) [homeassistant.components.updater] Could not contact Home Assistant Update to check for updates
2020-03-05 13:50:34 ERROR (MainThread) [homeassistant.components.updater] Error fetching Home Assistant update data: 

Also still getting this:

ERROR (MainThread) [homeassistant.components.synology.camera] Error when initializing SurveillanceStation
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/synology/camera.py", line 53, in async_setup_platform
    timeout=timeout,
  File "/usr/local/lib/python3.7/site-packages/synology/surveillance_station.py", line 12, in __init__
    self._api = Api(url, username, password, timeout, verify_ssl)
  File "/usr/local/lib/python3.7/site-packages/synology/api.py", line 60, in __init__
    self._initialize_api_sid()
  File "/usr/local/lib/python3.7/site-packages/synology/api.py", line 88, in _initialize_api_sid
    response = self._get_json_with_retry(api['url'], payload)
  File "/usr/local/lib/python3.7/site-packages/synology/api.py", line 192, in _get_json_with_retry
    return self._get_json(url, payload)
  File "/usr/local/lib/python3.7/site-packages/synology/api.py", line 207, in _get_json
    raise ValueError('Invalid or failed response', content)
ValueError: ('Invalid or failed response', {'error': {'code': 400}, 'success': False})

Thanks
Rob

1 Like

Same issue here, running Home Assistant 0.106.5

1 Like

Same here… Anyone solved this?

1 Like

Same, running 0.106.5

1 Like

Same here. Running 0.106.5

Seems to be working now. I was able to update just now.

1 Like

Just updated to the latest 0.106.6 but no change. Still getting the same errors.

For me also the same.
0.106.6 on Ubuntu VM.

After HA restart it’s working again…

I’ve got updater: in my config however not seeing the updater binary_sensor been created even after HA restart. Running 0.106.6. This got rid of the errors though. Any suggestions ?

I have the same problem too. Has anyone solved this? all my devices are not available

Anyone here running SmartIR, I think it might be todo with that and HomeKit.