[error] missing: apparmor

I’m trying to install home assistant on docker on Debian. But every time I run
curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s
I get this: [error] missing: apparmor. I could not find any matching topic on that. Also, my every post about it on Facebook or StackOverflow dies… Please help me!! :weary:

(I’m running on dell wyse Dx0d)



I may have solved the issue with sudo.
Can you try ?

You could try one of the easier installation methods if your Linux foo ain’t that skookum.

i tried with sudo, nothing :’(

can you mention these? I don’t know about other methods that can work on terminal


curl -sL “https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh” | sudo bash -s

1 Like

I encountered the same problem. By default on this debian version, when you su as root, it doesn’t add /usr/sbin in the path and it makes the script fail.
as root, try:

export PATH=$PATH:/usr/sbin

then run the script again


This did the job for me. Thanks!

it just worked! thanks!

It works!! Thanks

This worked for me also , Thanks

You login as root from a strandard user with the command “su”. When you do that, you become superutilisator, but with your standard user env variables. And of course this user doesn’t have /usr/sbin in his path.
The good way to login as root is to use the command “su -”, it will takes root env variables, no need to do the export.