Error on some cards

Hi,

I’m using the mobile app, version 3.0.2-full. Mostly to access my frontend, not using the sensors on my phone. Anyway, I have 2 boards that fail in the app. Both were configured with GUI, not YAML. Both work in Firefox, on my laptop and that very same phone.

  • first one is the custom component ‘gallery-card’ where I get a “Custom element doesn’t exist : gallery-card”. I wasn’t too concerned about this, as I thought it might be a custom-component problem.
  • second one is new, as I tried to replace an horizontal/vertical cards by a grid. And I get, again only in the app the error : “this.toggleAttribue is not a function”. The grid only has button cards, where tap action is “more info” and hold action is “toggle”.

Do you think both problems could be linked or separate ? Any idea why ?

Check that android system webview is up to date on your device. Also check in Chrome for Android to see if the issue occurs there too.

Webview is the 66 version, on Android 9. No problem in any application.
Otherwise, I don’t use Chrome(ium) only Firefox, I’ll try to install it to test.
I’ve tried to run it with Webview Test, a small wrap above system webview, I get the same problem.

Webview 66 is completely oudated, they are up to version 84 now I think.

Yes, but I don’t have any update proposed ? And I can’t set another browser as webview in the dev tools on this one.
Tried on another phone, with v71, grid works but not the gallery card.
Weird thing, I have 66 on an Android 9, and 71 on a 7 x86 version !

I had a similar issue with my Samsung Tablet until I updated both webview and Google Chrome. I wasn’t able to view grids nor markdowns.