Error requesting ESPHome Dashboard data: Cannot connect to host 127.0.0.1:63211 ssl:default [Connect call failed ('127.0.0.1', 63211)]

Hi, folks! Any idea how to fix this error? Anyone else having this issue with the new ESPHome version 2023.4.3?

I know it has something to do with docker and networking (obviously) but no clue why it appears. I cannot Submit a new ESPHome node because of this error. I tried uninstalling and reinstalling ESPHome.

I’m running an older version of ESPHome (2023.3.2) and see this too.

I just assumed it was because the ESPHome addon is not running and home assistant tried to communicate with it. I just tested that theory by starting the addon then restarting home assistant.

No error. So that could be it.

Is your ESPHome addon running?

Wait. You were saying you ESPHome was not actually running?

Mine is running. And it seems to be working fine. Except it reports that error I mentioned and the fact that I am not allowed to add new nodes. Here is what it is saying in the Add-on Log:


s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting
-----------------------------------------------------------
 Add-on: ESPHome
 ESPHome add-on for intelligently managing all your ESP8266/ESP32 devices
-----------------------------------------------------------
 Add-on version: 2023.4.3
 You are running the latest version of this add-on.
 System: Home Assistant OS 10.1  (armv7 / raspberrypi3)
 Home Assistant Core: 2023.4.6
 Home Assistant Supervisor: 2023.04.1
-----------------------------------------------------------
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-timezone: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
[00:53:25] INFO: Configuring timezone (Europe/Bucharest)...
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service base-addon-timezone successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-nginx: starting
s6-rc: info: service esphome: starting
s6-rc: info: service esphome successfully started
s6-rc: info: service init-nginx successfully started
s6-rc: info: service nginx: starting
s6-rc: info: service nginx successfully started
s6-rc: info: service discovery: starting
[00:53:28] INFO: Waiting for ESPHome dashboard to come up...
[00:53:29] INFO: Starting ESPHome dashboard...
2023-05-03 00:53:32,380 INFO Starting dashboard web server on unix socket /var/run/esphome.sock and configuration dir /config/esphome...
[00:53:32] INFO: Starting NGINX...
[00:53:34] INFO: Successfully send discovery information to Home Assistant.
s6-rc: info: service discovery successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
2023-05-03 00:55:32,770 INFO 304 GET / (0.0.0.0) 46.61ms
2023-05-03 00:55:32,867 INFO 200 GET /static/fonts/material-icons/material-icons.css?hash=ead4c276 (0.0.0.0) 64.29ms
2023-05-03 00:55:32,882 INFO 200 GET /static/css/esphome-2.css?hash=e81a30ae (0.0.0.0) 9.62ms
2023-05-03 00:55:32,888 INFO 200 GET /static/fonts/material-icons/MaterialIcons-Regular.woff2?hash=570eb838 (0.0.0.0) 12.11ms
2023-05-03 00:55:32,917 INFO 200 GET /static/js/esphome/index-67cb530c.js (0.0.0.0) 38.89ms
2023-05-03 00:55:32,993 INFO 200 GET /static/js/esphome/c.a24dad9a.js (0.0.0.0) 14.16ms
2023-05-03 00:55:33,007 INFO 200 GET /static/js/esphome/c.abbbe9de.js (0.0.0.0) 10.11ms
2023-05-03 00:55:33,014 INFO 200 GET /static/js/esphome/c.bc0ca5c5.js (0.0.0.0) 13.19ms
2023-05-03 00:55:33,078 INFO 304 GET /devices (0.0.0.0) 10.15ms
2023-05-03 00:55:33,248 INFO 200 GET /static/images/logo-text.svg (0.0.0.0) 11.67ms
2023-05-03 00:55:33,253 INFO 200 GET /static/fonts/material-icons/MaterialIcons-Regular.woff2 (0.0.0.0) 12.99ms
2023-05-03 00:55:33,299 INFO 200 GET /static/js/esphome/c.e7806b41.js (0.0.0.0) 213.10ms
2023-05-03 00:55:33,709 INFO 200 GET /static/js/esphome/c.5cd5d307.js (0.0.0.0) 28.75ms
2023-05-03 00:55:33,725 INFO 200 GET /static/js/esphome/c.2fd5868c.js (0.0.0.0) 11.54ms
2023-05-03 14:12:34,711 INFO 304 GET / (0.0.0.0) 70.58ms
2023-05-03 14:12:34,752 INFO 200 GET /static/fonts/material-icons/material-icons.css?hash=ead4c276 (0.0.0.0) 10.57ms
2023-05-03 14:12:34,774 INFO 200 GET /static/css/esphome-2.css?hash=e81a30ae (0.0.0.0) 6.81ms
2023-05-03 14:12:34,793 INFO 200 GET /static/fonts/material-icons/MaterialIcons-Regular.woff2?hash=570eb838 (0.0.0.0) 9.26ms
2023-05-03 14:12:34,818 INFO 200 GET /static/js/esphome/index-67cb530c.js (0.0.0.0) 21.29ms
2023-05-03 14:12:34,896 INFO 200 GET /static/js/esphome/c.a24dad9a.js (0.0.0.0) 11.60ms
2023-05-03 14:12:34,913 INFO 200 GET /static/js/esphome/c.abbbe9de.js (0.0.0.0) 13.26ms
2023-05-03 14:12:34,918 INFO 200 GET /static/js/esphome/c.bc0ca5c5.js (0.0.0.0) 11.08ms
2023-05-03 14:12:34,988 INFO 304 GET /devices (0.0.0.0) 16.96ms
2023-05-03 14:12:35,143 INFO 200 GET /static/js/esphome/c.e7806b41.js (0.0.0.0) 140.98ms
2023-05-03 14:12:35,160 INFO 200 GET /static/fonts/material-icons/MaterialIcons-Regular.woff2 (0.0.0.0) 11.48ms
2023-05-03 14:12:35,169 INFO 200 GET /static/images/logo-text.svg (0.0.0.0) 16.60ms
2023-05-03 14:12:35,533 INFO 200 GET /static/js/esphome/c.5cd5d307.js (0.0.0.0) 18.88ms
2023-05-03 14:12:35,549 INFO 200 GET /static/js/esphome/c.2fd5868c.js (0.0.0.0) 9.82ms

Yeah if I’m not using the addon to configure devices I turn it off.

Looks like my theory does not hold water though if yours is running.

you don’t need ESPHome add-on running to actually have access to ESPHome devices? :open_mouth:

No you don’t. That is all handled by the home assistant integration.

1 Like

I see. And from this respect, do I have an issue with the add-on or the integration? What do you think?

From this it would appear to me to be either the addon or the supervisor: “Error requesting ESPHome dashboard data”

Probably the supervisor as I am on the last version of ESPHome.

1 Like

I restored the previous HA backup and I don’t have the issue anymore. Using ESPHome v 2023.4.2 now.

I guess I won’t be updating anytime soon.

I suspect that is coincidence. As I said, I am on version 2023.3.2 of ESPHome and I see the error occasionally too.

The problem is I could not get rid of it.

BTW, to get things weirder I happen to have 2 versions of ESPHome as optional add-ons. It did not help that I got rid of one of them.

Now in v 2023.4.2 I still have the 2 options but no issues. I mention this that perhaps it has something to do with it.

I did get that error, too, today.

It’s a bit unfavorable that this comes up as an error. I suspect that this has purely to do with the timing of booting. So that HA expects ESPHome to be ready, but it’s not (yet).

…I have this error too. I’m on hassos, up to date version for ESPHome (2023.5.5) and HA (2023.5.4). I also agree that should be some kind of problem with ESPhome addon not being yet ready when restarting, because I have only 1 error, at time of starting and no more of this error so far (next 14 hours).