Error setting up entry Configuration.yaml for netatmo

I get an successful response when I integrate Netatmo, but nothing works and I get the response “Error setting up entry Configuration.yaml for netatmo” in the logs.
I only have the weather station so I suppose it would be fairly straight forward. I got it working in previous releases <0.105.

Logs look like this:

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/homeassistant/", line 216, in async_setup
    hass, self
  File "/usr/local/lib/python3.7/dist-packages/homeassistant/components/netatmo/", line 96, in async_setup_entry
    AUTH: api.ConfigEntryNetatmoAuth(hass, entry, implementation)
  File "/usr/local/lib/python3.7/dist-packages/homeassistant/components/netatmo/", line 27, in __init__
  File "/home/chrille/.homeassistant/deps/lib/python3.7/site-packages/pyatmo/", line 88, in __init__
  File "/home/chrille/.homeassistant/deps/lib/python3.7/site-packages/requests_oauthlib/", line 79, in __init__
    self.token = token or {}
  File "/home/chrille/.homeassistant/deps/lib/python3.7/site-packages/requests_oauthlib/", line 129, in token
AttributeError: 'WebApplicationClient' object has no attribute 'populate_token_attributes'

For some reason the token doesn’t seems to be updated, can it be some file that is “locked”?
Thankful for some support, not able to solve this one.

Did you read the breaking change in the release notes for 0.105?

I would suggest deleting everything related to netatmo (integration and configuration.yaml entry) and then work through the docs from start to finish.

1 Like

Yes, I have read that part and removed everything and started all over again. Searched and read most of the threads for Netatmo quickly to find something that could solve my problem. Also created a new app at Netatmo to get a fresh start. But apparently I have missed something…

Since you only have a weather station you can actually just as well use the HA Cloud, so, nothing needs to be configured in the yaml. But that is not your issue right now.

Please check your installed HA and pyatmo versions.

I tried without yaml configuration but I couldn’t authenticate with dev netatmo succesfully.

arch x86_64
dev false
docker false
hassio false
os_name Linux
os_version 4.15.0-91-generic
python_version 3.7.7
timezone Europe/Stockholm
version 0.107.7
virtualenv false

Pyatmo 3.3.0 - not sure on this one. How to check to be sure? This is stated in the folder

You should be able to authenticate via HA Cloud with your normal Netatmo account.

I don’t have HA cloud account, so my previous response when I tried without yaml settings shouldn’t work by that I suppose.
Would prefer to get this working without HA cloud as I don’t have any use for that except Netatmo weather station in that case.

Is there some cache of token storage that I can remove to have a totally fresh new try?

But you would support development of HA :slight_smile: and have an easy way to access HA remotely.

You don’t need a Nabu Casa account for that to work. HA cloud is a free service for account linking.

The token is stored in ~/.homeassistant/.storage/core.config_entries.

I agree on supporting HA development. But I allready have a good remote access working with many clients, would be some effort to change that.

Got the same error response for the HA cloud also, successful response but same error in the log as first post. With this addition:
Error setting up entry Home Assistant Cloud for netatmo

My config entries for Netatmo was cleared as it should when I removed the integration ~/.homeassistant/.storage/core.config_entries

I have never seen that error. This is set up under linux without any other layer such as Docker or venv?

No Docker or venv. Installed on Ubuntu 18.04 Desktop
Checked the requests_oauthlib and it is on version 1.3.0 which should be correct.
~/.homeassistant/.storage/core.config_entries looks correct and token etc. is stated in the file after authentication successful towards dev Netatmo.

I am also using Domoticz (planning to end that) which also grab data from Netatmo, they shared the same Netatmo app first but now I have separated HA and Domtoticz in individual apps due to this issues.

I’d like to suggest to start a clean instance in a virtual environment to make sure the dependencies are not messed up somehow. This should not take too much time.

I will do that, this PC have run as a server for many years and start to be a bit messy. It is on the to do list to install everything fresh again but it so many tweaks and fixes so it is some effort in total.

Will do some more test in venv or on a Rpi and come back, but will be busy for some days I think until I will have time.


1 Like

Successful connection on new installation (Ubuntu server 19.10 on Pi4) after some retries.
I think my actual issue was on the Netatmo side because I first get the exact same response on Pi4 as my old installation. I had many third party apps with same name and I think it get messed up, after a clean up I got it working.

1 Like

Great. Have fun automating!

Please stop cross posting, especially in such old threads.

How is your instance set up and exposed?


I have a new installation of Home Assistant on RPi4 and wanted to connect my Netatmo station with the same issue. Any advice, please? I am completely new to HA in general so maybe I am missing something obvious.

Logger: homeassistant.config_entries
Source: helpers/
First occurred: 10:53:55 (1 occurrences)
Last logged: 10:53:55

Error setting up entry Home Assistant Cloud for netatmo
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 304, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 230, in async_setup_entry
    await register_webhook(None)
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 181, in register_webhook
    webhook_url = hass.components.webhook.async_generate_url(
  File "/usr/src/homeassistant/homeassistant/components/webhook/", line 69, in async_generate_url
    get_url(hass, prefer_external=True, allow_cloud=False),
  File "/usr/src/homeassistant/homeassistant/helpers/", line 116, in get_url
    raise NoURLAvailableError

You have to configure external and intern urls in the settings. Further you have to expose your instance via port 443 unless you already use the Nabu Casa remote access.