Error setting up entry Envoy

Dear all,

I’m trying to set up my Enphase Envoy solar system, but I’m recieving an error which I can’t explane.
I know about the issues with the 7.X.X firmware, so I installed a package due HACS (GitHub - gtdiehl/EnphaseEnergy: Various collected information about Enphase Energy solar system)

After installing I see this error:

Logger: homeassistant.config_entries
Source: custom_components/enphase_envoy/ 
Integration: Enphase Envoy (DEV) 
First occurred: 14:43:00 (6 occurrences) 
Last logged: 17:05:09

Error setting up entry Envoy 122XXXXXX for enphase_envoy
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 388, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/config/custom_components/enphase_envoy/", line 131, in async_setup_entry
    hass.config_entries.async_setup_platforms(entry, PLATFORMS)
AttributeError: 'ConfigEntries' object has no attribute 'async_setup_platforms'

Does anybody have an idea how to fix this?

Many thanks in advance!

That custom integration must be updated.
async_setup_platforms was finally removed in 2023.5 (I think)

I’m using this one, it works fine for me:

Many thanks for your help guys.
I changed the installation to the version of braincmpbll, and changed line 131 of /config/custom_components/enphase_envoy/ to hass.config_entries.async_forward_entry_setups.

But I integration is stil getting an error, showing:

Logger: homeassistant.config_entries
First occurred: 16 augustus 2023 om 22:54:49 (21 occurrences) 
Last logged: 16:43:35

Config entry 'Envoy 1XXXXX' for enphase_envoy integration not ready yet; Retrying in background

I let it run for 24 hours, but I didn’t solve the problem.
Anyone how could help me with this issue?

I didn’t and have no problems. I’m not sure that “fix” is meant for this repo, I think it is for another one:

I fixed it :slight_smile:
I was running an old version of HA, after updating HA the problem solved.

Many thanks for your help :slight_smile: