Error setting up frontend

I’m trying to install HA using docker. I’ve got it setup fine but I can’t get the frontend to work as I keep getting the following error during setup

08.02.18 10:37:23 (+0000) 2018-02-08 10:37:23 INFO (MainThread) [homeassistant.setup] Setting up frontend 08.02.18 10:37:23 (+0000) 2018-02-08 10:37:23 ERROR (MainThread) [homeassistant.setup] Error during setup of component frontend 08.02.18 10:37:23 (+0000) Traceback (most recent call last): 08.02.18 10:37:23 (+0000) File "/usr/local/lib/python3.6/site-packages/homeassistant/", line 196, in _async_setup_component 08.02.18 10:37:23 (+0000) result = yield from component.async_setup(hass, processed_config) 08.02.18 10:37:23 (+0000) File "/usr/local/lib/python3.6/site-packages/homeassistant/components/frontend/", line 318, in async_setup 08.02.18 10:37:23 (+0000) import hass_frontend 08.02.18 10:37:23 (+0000) ModuleNotFoundError: No module named 'hass_frontend' 08.02.18 10:37:23 (+0000) 2018-02-08 10:37:23 INFO (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=persistent_notification, service=create, service_data=title=Invalid config, message=The following components and platforms could not be set up: 08.02.18 10:37:23 (+0000) 08.02.18 10:37:23 (+0000) - [frontend]( 08.02.18 10:37:23 (+0000) 08.02.18 10:37:23 (+0000) Please check your config., notification_id=invalid_config, service_call_id=3033243568-1>

HA is working okay itself as I can see events being fired in the logs and the API is working. Any thoughts of how to resolve this?

Bit hard to say without seeing your config.yaml, but maybe you don’t have frontend: in your config? Please post a copy of your config here using the </> button to format the code for display.

My config is below. I don’t believe this is the issue as I have frontend: in my config and it looks more like I’m missing some sort of package rather than being a config issue.

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 5
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here:
  time_zone: Europe/London
  # Customization file

# Enables the frontend

# Enables configuration UI

# Enables support for tracking state changes over time

# View all events in a logbook

# Sensor
  - platform: yr
  - platform: time_date
      - 'time'

# Text to speech
  - platform: google

I would try reinstalling, other than that I’m at a loss :stuck_out_tongue:

Hmm it’s in Resin using a container so tried that a couple of times. Anyone else have an idea?

So you tried re-flashing it with etcher using a new download? I’m assuming this is from your previous comment and if it is you would be better off asking in the forum.

I’ve not tried that but can’t see how re-flashing it with the resinOS would resolve the issue. It’s not using no, it’s my own setup using Resin.