Error setting up Govee local integration: Address in use

Hello Folks,

I am encountering an issue while trying to set up the Govee local integration in Home Assistant. I would appreciate any help or guidance in resolving this problem.

Error Details:
I am receiving the following error when setting up the Govee local integration:

Error setting up entry Govee light local for govee_light_local
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 551, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/usr/src/homeassistant/homeassistant/components/govee_light_local/", line 24, in async_setup_entry
    await coordinator.start()
  File "/usr/src/homeassistant/homeassistant/components/govee_light_local/", line 48, in start
    await self._controller.start()
  File "/usr/local/lib/python3.12/site-packages/govee_local_api/", line 98, in start
    self._transport, self._protocol = await self._loop.create_datagram_endpoint(
  File "/usr/local/lib/python3.12/asyncio/", line 1421, in create_datagram_endpoint
    raise exceptions[0]
  File "/usr/local/lib/python3.12/asyncio/", line 1405, in create_datagram_endpoint
OSError: [Errno 98] Address in use

System Information:

  • Home Assistant version: 2024.4.0
  • Installation type: Home Assistant OS
  • Govee local integration version: Latest from HACS

Additional Context:

  • I am also running the Govee2MQTT integration alongside the Govee local integration.
  • I have tried configuring the Govee local integration through the Home Assistant UI (Integrations page) as YAML configuration is not supported.
  • The error occurs consistently whenever I try to set up the Govee local integration.

Troubleshooting Steps Tried:

  • Restarting Home Assistant
  • Checking for conflicting applications or services using the same port
  • Reviewing Home Assistant logs for additional error messages

I would greatly appreciate any suggestions, workarounds, or insights into resolving this “Address in use” error and successfully setting up the Govee local integration.

Thank you in advance for your help!