Error setting up hue component

This was working for weeks until today. Suddenly lost all my hue lights. Just updated to 0.66.1.

Error while setting up platform hue
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/helpers/”, line 82, in async_setup
SLOW_SETUP_MAX_WAIT, loop=hass.loop)
File “/usr/lib/python3.6/asyncio/”, line 358, in wait_for
return fut.result()
File “/usr/lib/python3.6/site-packages/homeassistant/components/light/”, line 56, in async_setup_platform
bridge =[hue.DOMAIN][discovery_info[‘host’]]
KeyError: ‘host’

And did you read the release nodes, section “breaking changes”? Property “host” in hue is no longer optional and even worse - it has to be an IP address, not a DNS name.

I do already have it set up that way, but appreciate the suggestion!

That’s mine, have error

    - host:

I do have the same, but with allow hue groups

Still the same error, what is the solution here ?


check if you have enough free space

Solved this by updating my custom hue sensors component from robmarkcole

how do you update the custome hue compent ?
I needed at to get access to the hue motion sensor etc.

If i remove it, it works fine, but i lost the connectivitiy to the hue motion sensor

Yes, more then enough space free.

Very strange this issue.


You need to go to his github and download the updated version. Then just write over your previous custom component.

it is along time ago i did the custom component :slight_smile:

i do not know where it was, guess i have to search for it then again on the weekend.