Error setting up platform google_maps

Hello, can anyone help me with my botched google maps location sharing? Im using hassio and deleted the location sharing cookie file in an attempt to get the component running with two devices. Thanks for any help

Error setting up platform google_maps
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 184, in async_setup_platform
  File "/usr/lib/python3.6/concurrent/futures/", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 36, in setup_scanner
    scanner = GoogleMapsScanner(hass, config, see)
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 55, in __init__
  File "/usr/lib/python3.6/site-packages/homeassistant/components/device_tracker/", line 67, in _update_info
    for person in self.service.get_all_people():
  File "/usr/lib/python3.6/site-packages/locationsharinglib/", line 292, in get_all_people
    return self._get_data()
  File "/usr/lib/python3.6/site-packages/cachetools/", line 46, in wrapper
    v = func(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/locationsharinglib/", line 283, in _get_data
    output = json.loads(response.text.split("'", 1)[1])
  File "/usr/lib/python3.6/json/", line 354, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.6/json/", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.6/json/", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)`

Turns out it was due to a refresh interval. I waited a few hours and reloaded HA and know everything is working accordingly.

I have the same issue. Can we limit refresh interval or fix this issue somehow?

I just installed today, and have added myself, my wife, and three of my four kids. However, one of the kids is missing from the list. I’ve confirmed that I can see the missing one on Google Maps, but it just isn’t showing up. I’m hoping it’s refresh interval, but any thoughts on troubleshooting threads to pull if it doesn’t show up eventually?

waiting an hour or so did work. I am, however, repeatedly having to do “i am not a robot” on multiple computers across my home network.

I’ve had to do this a few times too

I approve mine on the activity page, however no device with google entity is shown. I have 2 android shared with the email. I do not know what it can be anymore, does anyone have an idea?

From a troubleshooting standpoint, I’d say start with the google account that you’re using for the Home Assistant.
Personally, I set up a separate account to use so that I could track everyone, myself included. I shared all of the accounts to be tracked to it, with “until I turn this off”, and then verified that I could see them in Google Maps.

That confirmed, I added the code to the Configuration.yaml file to set up the tracker.

After this, I restarted the device, and was able to see the entities to be tracked.

Now; when I added them one at a time, it took some time for them to show up after the 3rd or 4th one was added. This, as I understand it, is something that is related to Google, rather than to Home Assistant.

If you want to share your code, we can see if something stands out. :slight_smile:

I have the same issue. Any way to fix it?

I’m not even getting that myself. I added myself and get about the same error message but not showing a login ont he activity page so nothing to confirm. i got me and my wife showing. Should this be showing in the map section on HASSIO or do i need to add a google maps window?? Strange thing I’m not even getting an authentication screen…

You can see people at HASSIO map which are outside home.

I’m seeing this issue too. Is there a fix?

Has anyone got this resolved? I am having this issue as well. I saw on another page that deleting the google.maps.location.sharing.cookies file and then restarting has helped others but I have had no luck after trying that multiple times. Running a separate google account with 2factor disabled on a raspberry pi on Hassio 0.84.6 Any advice would be much appreciated!