Home Assistant Community

Error setting up rpi_rf RF Switch, no devices shown

#1

Hello Community,

I was impressed with the fast and easy setup of hass.io, unfortunately I ran into an Error:
Raspberry Pi RF Switch Devices are not showing up, neither in the Overview nor in the dev-state.
My configuration looks like the platform example. I get the following message in the log file: /config/home-assistant.log

2019-03-14 16:21:05 ERROR (MainThread) [homeassistant.components.device_tracker] Unable to load /config/known_devices.yaml: Config file not found: /config/known_devices.yaml
2019-03-14 16:21:05 ERROR (MainThread) [homeassistant.components.switch] Error while setting up platform rpi_rf
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/homeassistant/helpers/entity_platform.py", line 128, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/local/lib/python3.7/asyncio/tasks.py", line 416, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/homeassistant/components/switch/rpi_rf.py", line 50, in setup_platform
    import rpi_rf
  File "/usr/local/lib/python3.7/site-packages/rpi_rf/__init__.py", line 2, in <module>
    from .rpi_rf import RFDevice
  File "/usr/local/lib/python3.7/site-packages/rpi_rf/rpi_rf.py", line 9, in <module>
    from RPi import GPIO
  File "/usr/local/lib/python3.7/site-packages/RPi/GPIO/__init__.py", line 23, in <module>
    from RPi._GPIO import *
RuntimeError: This module can only be run on a Raspberry Pi!
2019-03-14 16:21:06 ERROR (SyncWorker_11) [homeassistant.components.ios.notify] The notify.ios platform was loaded but no devices exist! Please check the documentation at https://home-assistant.io/ecosystem/ios/notifications/ for more information

The first line can be avoided by manually creating an empty “/config/known_devices.yaml” file. But I have no idea how to solve the other lines.

I’m new to the Community as well as to Home Assistant, hopefully someone is able to help. Any idea on how to fix this is welcome. Thanks in advance!

#2

When using HASS.io you don’t get access to the underlying hardware, and for the RPi_rf you do need to access the GPIO pins. If you need RPi_rf switch you should try HASSbian or if you know your way around Linux - Raspbian with venv.

1 Like
#3

@kirichkov Thank you very much for your fast and competent response!

#4

Is accessing the GPIO pins and using rpi_rf within HASS.io planed for the near future?

#5

I’m not really knowledgeable of HASS.io but I think due to the use of docker that’s impossible. You might be able to achieve the same result using a Broadlink with 433MHz sender.

#6

Ok, probably every advantage comes with a downside as well. :smile:
Your suggestion using HASSbian works fine for me. Thanks again!