Error updating Home Assistant Supervisor

Hi all,

I have Home Assistant Operating System on a Raspberry, which has been functioning correctly for some months already. Since last week, it fails. Apparently it does not get access to internet. I can still manage devices within my internal network, but cannot conect to external things.

I cannot update the Home Assistant Supervisor. Currently I have the following version:

Home Assistant 2023.3.6
Supervisor 2023.03.2
Operating System 9.5

When I try updating, I get the error:

Error updating Home Assistant Supervisor: Abort update because of an issue with AppArmor: Can't fetch AppArmor profile Cannot connect to host ssl:default

Restarting HA or the router does not solve the problem. Nothing has changed in the configuration since it was working properly. The only fact that comes to my mind, because of what I read in posts here, is that last week they changed the hour in Spain.

Any ideas?
Thank you very much.

  • I tried restoring previous backups: didn’t work
  • I tried re-installing HA, by flashing the SD card, but BalenaEtcher raises an error when doing so

One way to check if a site is accessible to you is to try to access it through the browser on a computer or mobile device connected to the same network as your raspberry. If you can’t access the site, the problem is most likely related to your Internet connection or network. In this case, try rebooting your router or contacting your ISP to resolve the problem. If, on the other hand, you can access the site through your browser, the problem may be related to your Raspberry settings. You can check your system settings to make sure that no changes have been made that might affect its ability to establish a connection via HTTPS. You can also check the Home Assistant configuration files to make sure that they are configured correctly for your network and Internet connection.

1 Like