Error when calling scripts with iOS Shortcuts

Hi, I use NFC tag in tandem with iOS Shortcuts app and HA Mobile Companion App to call scenes. I do it with calling “scene.apply” service and “entity_id: scene.xxxx” payload.

I want to run script this way (calling script.turn_on service or directly script.scriptidXXX) but Shortcuts always responds with “Could not run call service, failed to call service with error: Unable to parse stored payload”.

How do I call a script with Shortcuts and HA Companion app? Running iOS 13.3.1 and HA 105.5

EDIT: I can’t even add new Scenes to run this way. The already added ones do run okay, but any new one results in the above error.

I had to put the payload data in the shortcuts app in {} and each pair in speech marks.

{"entity_id": "light.0x588e81fffe655b0b_light", "brightness":"Brightness", "color_temp":"Colour"}
1 Like

Thanks for this. For the information of anyone else with the same problem, I had a very simple shortcut set up that failed with this same message. It didn’t need any data, so I put just “{}” in as the data and it worked fine.

Hi all sorry to jump on an old thread, but stumbled on this one as I’ve got the same problem.
Whatever I do (passing in the JSON entity) or firing off a script call (with empty JSON) iOS is prompting “Could not run call service" which means any further actions in Shortcuts don’t get run.

Anyone else have any solutions that I could try?
Thank you

I have this same problem. Almost every time I run a shortcut with a call service or perform action, it fires but I get a “timed out”, even though the action in question did actually happen (lights were changed, door was unlocked, etc.)

I’m wondering if this isn’t a bug in the iOS app; maybe it’s not calling some sort of callback or something to let Siri know the action was performed successfully?

I am having the same problem as brownjava. The call action works (the light turns on) but siri gets stuck until it times out or I get the following error:

“Could not run call service
Failed: Error during api.callService: could not communicate with background transfer service”

Has anyone had any answers for these?

I’m having the same issue. The action works fine, but I’m getting the “Could not run Call Service: The operation took too long to complete. Please try again.” Even though it worked fine. Really annoying. Hope somebody finds a fix for this, because despite this error, everything is working beautifully.

I’m running into a very similar issue. I have an automation that sets an input_boolean to true when I go to sleep and resets it when I wake up. The automation in the evening is running fine. However, for some days now the call in the morning fails with the following message:

Failed: Error during api.callService:Could not communicate with background transfer service

I did not change anything related to this, at least not to my knowledge. Does it mean the server can’t be reached?

Same issue for me. This used to happen occasionally and now it seems to happen more frequently. The service (in this case a script) gets triggered fine on the HA side but Shortcuts continues to “wait” and times out with the described error which prevents the shortcut from continuing. Very frustrating.

It is possible this is improved in the latest iOS beta. This error is a system bug which I think I worked around.

I’m still getting this. Any luck solving this here?

Same here… no workaround?

Please share the error messages you are receiving.

I found the solution…
I am not sure I can post from another forum here but the solution is to use script.toggle and in the data send a dictionnary value that contains script.xxxxxx

IT WORKS!!