Error when opening the app from local network

I am using the app for my phone, and it works perfectly remotely and locally. Today I installed it on my wife’s phone. It can connect remotely but NOT locally. I am getting this error only:

Unable to connect to Home Assistant.
There was an error loading Home assistant, please review the connection settings and try again.

The settings seem to be fine (cmon, there are only 3 fields to setup)
Home assistant URL
Home Network WIFI
Internal connection URL
are all setup the same as my phone.

What is wrong here?

On your wifes phone do you need to accept a SSL cert in a browser? If so then local connection will not work as the SSL cert needs to be valid. In most cases if your router supports NAT Loopback then you want to use that and only use the external URL.

I am using ssl in my instance, so yea, I have to accept the cert. But that happens on my phone too. Why is my phone ok? Can I import the certificate somehow? I really dont want to use the loopback, since an internet interruption will render our phones useless.

Edit: Another reason I dont want the loopback, is because I intend to use the app on my tablet too (which is mounted near the entrance).

You probably imported the certificate locally on your device but not hers. There was a PR that works with imported certs: https://github.com/home-assistant/home-assistant-android/pull/194

Actually yes you do need to make sure the URL is valid and that you imported it to Androids trusted certificates

Thank you for your suggestion, but it looks like it still doesnt work. I had to convert the certificate from .pem to .crt in order to import it, but when I open the app, it doesnt work. Is there anything else I could do?

Try to clear data in the app after you imported the cert into android…see if that helps

Already tried that. Still no luck.