Error When Trying to Casting Lovelace

This has been working for a long time and and was not changed - but now doesnot work: This simple script which simply casts the default lovelace UI to a google nest hub max -

alias: Start Casting Dashboard (Lovelace/0)
  - service: media_player.turn_off
    data: {}
      entity_id: media_player.google_nest_hub_max
  - delay:
      hours: 0
      minutes: 0
      seconds: 1
      milliseconds: 0
  - service: cast.show_lovelace_view
      entity_id: media_player.google_nest_hub_max
      dashboard_path: lovelace/
      view_path: "0"
mode: single
icon: mdi:tablet-dashboard

All the script does it does is stop the casting (in case it already was), then waits one second, then (re)casts.

However, when the script is run it now shows this on the google nest hub max screen that it is casting to, instead of the lovelace ui:

Error loading the view strategy:
         TypeError: Cannot convert undefined or null to object

The above appears in the middle top of the google nest hub max screen and nothing else. There are no errors in the home assistant or syslogs.


My dashboards on various Google Hubs have changed recently as well. Odd changes. Some tiles appear as they are supposed to but camera streams don’t, an entities list card only shows a few of the entities, a weather tile doesn’t show and other oddities. Everything appears fine on mobile or on a desktop but when the dashboard is cast they don’t work correctly. I’ve restored a backup from a few days ago and still no luck. My guess is Google changed something on their end.

Yep. Same issue here. Was working perfectly on my Google Nest. Now I can still get the nest to display my selected dashboard but only a couple of tiles show all the rest are missing. Everything looks perfect on Home Assistant web or mobile app. If anyone finds a solution please let me know, I don’t fancy uninstalling and recreating everything just to find it doesn’t solve it.

Same issue here. The state-label missing from picture elements and some mushroom entity cards, too. I cast lovelace to 2 google nest hub (one 1st gen and one 2nd gen).

@Pavel_S and @spokerevolutions, I was going to report it as a bug but I saw there are already many google cast bugs shown as open anyway for a while which is dicouraging. I am reporting it anyway as mine might be different - and here is the link to it:

Seeing the same on my Google Nest Hub here. Only a few entities are showing up on the device being casted to. I’ve also tried casting to another device (Sony Bravia TV with Android TV) and it looks exactly the same, so the problem is not only with the Nest Hubs.

Also, it’s always the same entities showing up (or the same missing, if you look at it that way), so it’s not “random.”

I can confirm that my Nest Hub does not show correctly any more. I was three days away and when I came back today, an entity list did not show the content any more. Rebooting did not help

Same here, been doing some testing, and it really is card dependant, following cards do not work: Entities, sensors, and thermostat (which are basically the cards i need)

This really renders my nesthub max kinda useless

Same issue here. Gauge stopped working…

I would suggest you guys add your comments to this (or whichever open cast issue is most appropriate):

Same issue here. Only some (entity, photo, climate) cards are missing. No errors in the log. Any idea how to set this integration to debug logging?

@riggsdr I’d be very interested in that as well - how to debug this

Same problem here, really strange behaviour with the entity disapearing or not displaying at all.

Update to 2023.3.0 and it should be back working…

@dm82m That’s great news - but I son’t want to use a Beta, I’ll wait :slight_smile:

It is no beta. 2023.3.0 is the final March release. But anyways, do what you want.

@dm82m - yes I just got it - and it does solve the issue! Thank you. I guess you get the updates before I do!