Error while setting up rpi_gpio

Ok… so I installed on a rpi 3 tried the rpi gpio cover so that I can use it to open the garage door, didn’t work, nothing shows up on the overview… now i’ve installed Hassbian thinking there might have been a flaw in the install… same thing. Funny part about it though is i can install the switch rpi gpio straight from the web page and everything works. so can someone explain to me why the switch shows up but the cover won’t?


I found this in the Log… but i have no idea what its supposed to be. Noob here!

Error while setting up platform rpi_gpio
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/”, line 84, in async_setup
SLOW_SETUP_MAX_WAIT, loop=hass.loop)
File “/usr/lib/python3.5/asyncio/”, line 400, in wait_for
return fut.result()
File “/usr/lib/python3.5/asyncio/”, line 293, in result
raise self._exception
File “/usr/lib/python3.5/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/cover/”, line 69, in setup_platform
KeyError: ‘name’

Really! 24 hours and no one replies? what kind of community is this?

It’s a community made up of people that use the software. It’s made up.of people that spend their free time helping others for FREE.

If someone doesn’t understand the problem, why should they respond?

I would suggest you calm down and take a look at the error message. It looks to me like you have it misconfigured in your configuration yaml. If you want to post a copy of your configuration yaml with your private data redacted I’m sure someone would be glad to take a look, but you will first have to lose the attitude.

You’re Right, and I apologize… when I wrote this I was letting my anger and frustration get the better of me and I had to put this off for a couple of days so that I could calm down. Now that I have, It would be nice if someone could help me figure out the issue. Here is the only thing I have in the config.yaml file…

    - platform: bluetooth_tracker

    - platform: rpi_gpio
        - relay_pin: 10
        - state_pin: 11

Everything is literally copied and pasted from the Home Assistant site. The bluetooth tracker is working flawlessly. I even updated to the new version 63.3 hoping it would solve the issue but to no avail. Can someone please point me in the right direction since everything else I’ve done has worked without a hitch.
Also tested it with the switch component and I could Control the GPIO pins no ProblemPreformatted text

It really does look like your spacing is wrong there. Please note spacing in yaml is crucial.

Your lines look off.


Here is the File… I don’t see any spacing errors

I can’t view that on mobile. Can you copy contents to hastebin and provide a link?

Remove the dash from in front of your state_pin

It really can’t be that simple can it?

According to the documentation page for cover GPIO the state_pin doesn’t have a dash

Pretty sure I’ve tried it like that but i’m restarting now.

Yep. Same result…

The error indicates that it’s got a key error of name…

We’ll have to see if anyone else has any ideas.

I do appreciate your help. Sorry again for the attitude. I DO see how this frustrates many People especially those that are new to this but others that have been at it for a while…

1 Like