Error while starting zigbee-herdsman

Hi, Im trying to set up zigbee2mqtt. But it just say that zigbee-herdsman cant start.
I am totally new to this but have tried to follow tips from other threads and from YT but nothing works.
Here is the log

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/socat.sh
[19:46:20] INFO: Socat not enabled, marking service as down
cont-init: info: /etc/cont-init.d/socat.sh exited 0
cont-init: info: running /etc/cont-init.d/zigbee2mqtt.sh
cont-init: info: /etc/cont-init.d/zigbee2mqtt.sh exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun socat (no readiness notification)
services-up: info: copying legacy longrun zigbee2mqtt (no readiness notification)
[19:46:26] INFO: Handing over control to Zigbee2MQTT Core …

[email protected] start
node index.js
Zigbee2MQTT:info 2022-08-14 19:46:39: Logging to console and directory: ‘/config/zigbee2mqtt/log/2022-08-14.19-46-39’ filename: log.txt
Zigbee2MQTT:info 2022-08-14 19:46:39: Starting Zigbee2MQTT version 1.27.0 (commit #unknown)
Zigbee2MQTT:info 2022-08-14 19:46:39: Starting zigbee-herdsman (0.14.46)
Zigbee2MQTT:error 2022-08-14 19:46:50: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-08-14 19:46:50: Failed to start zigbee
Zigbee2MQTT:error 2022-08-14 19:46:50: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-08-14 19:46:50: Exiting…
Zigbee2MQTT:error 2022-08-14 19:46:50: undefined

here is my config
data_path: /config/zigbee2mqtt
socat:
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: “-d -d”
log: false
mqtt:
base topic: zigbee2mqtt
mqtt: ¨¨
server: mqtt://192.168.1.8:1883
user: mqtt
Password: Zigbee2mqtt
serial:
serial: null
port: /dev/ttyAMA0
adapter: deconz
zigbee_herdsman_debug: false

For sure your indentation is wrong…but maybe by accident?

But at first glance seems to be ok…maybe usb port setting are wrong?
It is better to use ‘by-id’ as it never changes…

serial:
  port: >-
    /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2481787-if00
  adapter: deconz #required when using conbee😉

I also noted mqtt twice? and one of them with “” ??
should be:

mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://192.168.1.9
  user: <my mqtt user>
  password: <my mqtt password>

tried it now but did not work now it says

[email protected] start
node index.js
Zigbee2MQTT:info 2022-08-14 20:45:26: Logging to console and directory: ‘/config/zigbee2mqtt/log/2022-08-14.20-45-25’ filename: log.txt
Zigbee2MQTT:info 2022-08-14 20:45:26: Starting Zigbee2MQTT version 1.27.0 (commit #unknown)
Zigbee2MQTT:info 2022-08-14 20:45:26: Starting zigbee-herdsman (0.14.46)
Zigbee2MQTT:error 2022-08-14 20:45:27: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-08-14 20:45:27: Failed to start zigbee
Zigbee2MQTT:error 2022-08-14 20:45:27: Check Zigbee2MQTT fails to start | Zigbee2MQTT for possible solutions
Zigbee2MQTT:error 2022-08-14 20:45:27: Exiting…
Zigbee2MQTT:error 2022-08-14 20:45:27: Error: Error while opening serialport ‘Error: Error: No such file or directory, cannot open /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2481787-if00’
at SerialPort. (/app/node_modules/zigbee-herdsman/src/adapter/deconz/driver/driver.ts:200:28)
at SerialPort._error (/app/node_modules/@serialport/stream/lib/index.js:198:14)
at /app/node_modules/@serialport/stream/lib/index.js:242:12

ah… but that is the ID of my system, you’ll have to find the id of yours….

ooh okey. How do i do that

Goto settings/system/hardware and hir the three dots in upper right corner, and select ‘all hardware’

Somewhere in the tty section your adapter should pop up

Ps
I also noted mqtt twice? and one of them with “” ??
should be:

mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://192.168.1.9
  user: <my mqtt user>
  password: <my mqtt password>

I fixed that. But i cant find my ID
this is all is says under ttyAMA0
Subsystem:tty

Device path:/dev/ttyAMA0

Attributes:

DEVLINKS: /dev/serial1 DEVNAME: /dev/ttyAMA0 DEVPATH: /devices/platform/soc/3f201000.serial/tty/ttyAMA0 MAJOR: ‘204’ MINOR: ‘64’ SUBSYSTEM: tty TAGS: ‘:systemd:’ USEC_INITIALIZED: ‘7073262’

Do from the CLI:

ls -l /dev/serial/by-id/

The above command should output the exact ID you are searching for (linked to: → …/…/ttyAMA0).

Also above is incorrect.

You should use the </> when pasting code; as this is yaml and indentation is very important

PS: regarding the port settings, it is better to use ‘by-id’, but

port: /dev/ttyAMA0

is correct (however, there is a change it changes when f.e. using a different port)

I tried it and it did not work

Hey,
I just had the same problem but I got it working. I started with the deConz-AddON and Phoscon but after one update Phoscon always said that the firmware is not connected. That was the reason why I wanted to migrate to zigbee2mqtt. I set this up just like you and had the same error. Then I tried the to get it working on my Windows PC Link and I had the same problem (firmware not connected and clicking the connect button does nothing). Next I just downloaded the last firmware update and installed the update with the GCCFlasher. Here is the manual to do this: Update deCONZ manually · dresden-elektronik/deconz-rest-plugin Wiki · GitHub

After that my Windows deConz immediately displayed the connected firmware. At last I put the stick in my Raspberry Homeassitant again and restarted the zigbee2mqtt-add-on → zigbee-herdsman started succesfully. There was another problem in my config because I forgot to insert the created user and password in the mqtt-area.

user: mqtt-user
password: <password>

Make sure to create a user in homeassistant for this.

Hope this helps!