Home Assistant Community

Error while trying to install zigbee2mqtt on Hassio


Hi all

hope this is the right forum. I am still new to Home Assistant. I have my Hassio on a RPI3 and want to setup Zigbee2Mqtt with the CC2531 sniffer. I’ve followed the guide to flashing the dongle and that all seemed to work as it should

I’ve then added the danielwelch rep from https://github.com/danielwelch/hassio-zigbee2mqtt but when I press install under the add-ons, the buttom turns red after a few sec and I get the following error

19-03-09 05:42:55 INFO (SyncWorker_2) [hassio.docker.interface] Pull image dwelch2101/zigbee2mqtt-armv7 tag 1.1.1.
`19-03-09 05:42:58 ERROR (SyncWorker_2) [hassio.docker.interface] Can't install dwelch2101/zigbee2mqtt-armv7:1.1.1 -> 404 Client Error: Not Found ("pull access denied for dwelch2101/zigbee2mqtt-armv7, repository does not exist or may require 'docker login'").`

I’ve tried googling every part of the error message, but been unable to find anything so solve my issue, so I hope some of your good people might be able to help me :slight_smile:


Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)

ill be following i want to use this too



I have it running I confirm I use the same add on repro as you’re using. Not sure if it is down temporarily?
Are you able to pull other addons from that repro or other repro?



I have also reported this in main thread: Zigbee2mqtt: getting rid of your proprietary Zigbee bridges (Xiaomi, Hue, TRADFRI)



Thanks for answering. There is only the two apps on the reb, the zigbee2mqtt and then the edge version. Neither are able to pull
I tried installing other apps from the main rep and that worked fine !



Opened a PR to fix this:

1 Like


Arh so just for my own understanding, it is because I just updated to the newest version of hassio and the app is not supporting this one ?



Partly true. Hassio added support for an additional architecture, armv7. The add-on does not specify which architectures it supports, hence Hass.io assumes it supports all, which it doesn’t. I’ve opened a PR to correct that.