Error with command_line switch


I have cammand_line switch in my configuration.yaml to startup and shutdown my pc.

This worked fine before updating to the latest version.
But every time I try to reboot now I get this error.

I tried to move the config to a command_line.yaml and use command_line: !include command_line.yaml but this doesn’t work either.

Hope anyone can help me

You need to change the format as per the breaking change in the release notes and the 100 other posts on this topic.

Also please don’t post pictures of text. Post the text correctly formatted for the forum.

Hey tom,

Could you help me set this up?
I’ve been trying to fix it for the last couple of hours and I really can’t find a solution for it to work again.

The screenshot in your first post shows that you moved the configuration of all of your sensors under the command_line: key.

You’re only supposed to move the configuration of Command Line sensors under the command_line: key (you also moved Wake On Lan, Template, etc). In addition, the configuration format for Command Line sensors has changed slightly so you can’t simply copy the old configuration format and paste it under the command_line: key.