Error with media stream contents (bufferAppendError)

Hi,

I’m trying to play the live stream of my dahua camera directly in a Lovelace Card but when I want to load it, after a few seconds, this error occurs : “Error with media stream contents (bufferAppendError)”.

Here is my configuration.ytml, I tried both generic and ffmpeg methods but it doesn’t change anything.

ffmpeg:
stream:
camera:
  - platform: generic
    name: "entrée"
    still_image_url: "http://ip/cgi-bin/snapshot.cgi"
    stream_source: "rtsp://admin:password@ip:port/cam/realmonitor?channel=1&subtype=1"
    username: admin
    password: ********
    authentication: basic
    verify_ssl: false
  - platform: ffmpeg
    name: "entrée2"
    input: "rtsp://admin:password@ip:port/cam/realmonitor?channel=1&subtype=1"

The rtsp link is working on VLC.

I hope you can help me,
thanks in advance

Did you ever get this resolved?

My cameras (ONVIF) were working fine with the stream: Integration disabled but since I recently enabled stream: one of my 4 cameras gives the ‘BufferAppendError’.
image

Have the same issue, works on VLC, but cannot display the stream contents in HA

I get the same error on my Reolink cameras occasionally. However mine doesn’t say BufferApendError - all I get is this:

Error with media stream contents. Check troubleshooting. It’s possible that the error reporting has been updated to not show the actual error?

This happens every so often. Refreshing the page takes care of it.