Error with Notifications on Android App

I bought a few door sensors and I want to have them notify us on our phones when the doors open. I have the automation setup, and when I first set it up it worked fine. The problem is that after a few hours it stops working. And if I go through the steps to troubleshoot I find that when I go to “run action” on the automation I get this:

Error running action

Unable to find notify service for webhook ID

I have only been able to resolve this by uninstalling and reinstalling the app - it then works fine for a few hours before I run into more issues.

Does anyone know what might be causing this and how to prevent it? I was hoping to use this as a makeshift alarm system but it’s too unreliable to use for this purpose.

My wife and I both have the Pixel 6 Pro.

Edit: in doing some further testing, this happens when I reinstall on the other phone. So I’m only able to get notifications on the phone I setup most recently.

What are the entity_id’s of the two phones?

They defaulted to device_tracker.pixel_6_pro and pixel_6_pro_2, but I see the same issue when I changed the entity names. The device names are Danielle Phone and Mike Phone.

I am noticing that even on the one that’s working it seems to be a bit unreliable even with it set to unrestricted battery usage. It will sometimes not sound until after I pick up my phone. Maybe a z-wave chime would be better.

Try starting fresh on the devices having an issue. Make sure to set the name of the device to be unique before clicking on finish.

Read the docs to also find out how to speed up delivery of notifications

Generally when a device is given a _2 entity_id it is a sign ha is getting confused between the two.

this was my problem. I had ‘iphone 13’ & ‘iphone 13 Primary’. When I selected the other one it worked.