Error with zeroconfig after upgrade to 0.118.5

I upgraded HA to 0.118.5 because i had problems with tss. But now my Shelly devices are no longer recognized/integrated.
I get this Notification in the UI:

Invalid config
The following integrations and platforms could not be set up:

Please check your config and logs.

And I receive this error in my log:

Logger: homeassistant.setup
Source: components/zeroconf/
First occurred: 9:28:12 AM (2 occurrences)
Last logged: 9:28:16 AM

Error during setup of component zeroconf
Error during setup of component discovery
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 213, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/zeroconf/", line 142, in async_setup
    zeroconf =[DOMAIN] = await _async_get_instance(hass, **zc_args)
  File "/usr/src/homeassistant/homeassistant/components/zeroconf/", line 90, in _async_get_instance
    zeroconf = await hass.async_add_executor_job(partial(HaZeroconf, **zcargs))
  File "/usr/local/lib/python3.8/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.8/site-packages/zeroconf/", line 2394, in __init__
    self._listen_socket, self._respond_sockets = create_sockets(
  File "/usr/local/lib/python3.8/site-packages/zeroconf/", line 2319, in create_sockets
    respond_socket = add_multicast_member(cast(socket.socket, listen_socket), i, apple_p2p=apple_p2p)
  File "/usr/local/lib/python3.8/site-packages/zeroconf/", line 2264, in add_multicast_member
    listen_socket.setsockopt(socket.IPPROTO_IP, socket.IP_ADD_MEMBERSHIP, _value)
OSError: [Errno 105] No buffer space available

Up until now I used ShellyForHass for the integration. But I read that since version 0.115, Shelly is default integrated in Home Assistant. So i tried with removing ShellyForHass, and there is a Shelly Device recognized but without entities…
So I installed ShellyFor Hass again, but without changes…
I also followed the announcements for version 1.0.0 where Shelly will be better integrated…

Any idea if I have to change anything to my config or that this might be a bug in 0.118.5 or that this is a known issue and it will be fixed in 1.0.0?

EDIT: Ai, I restored a Snapshot from before the upgrade to 0.118.5, and the problem persists.
So perhaps there is an completely different problem…

I just got some of the same errors. Out of the blue. After a restart. Everything has been running fine and dandy before that.

Edit: I have been investigating and it seems that I have reached the limit of what the PI is capable of. I am running too many dockers now. Maybe too many services or open sockets.

OSError: [Errno 105] No buffer space available

System is overloaded? Will investigate further if it is possible to fine tune.

  • So this has nothing to do with HA per se.

  • Shutting down some dockers fixed it.


Modify net.ipv4.igmp_max_memberships in /etc/sysctl.conf .

You can reload the configuration file by using sysctl -p or by rebooting your system.

If the line don’t exist, append it. Here’s an example with a new limit of 75:

net.ipv4.igmp_max_memberships = 75

Default number is 20. You can check with:

sysctl net.ipv4.igmp_max_memberships

This fixed it for me.

1 Like