Errornous re-triggering of leave zone

Tags: #<Tag:0x00007fc418b6b3c0>

Hi

I got a bit adventurous and tried automatically letting me know when the wife was coming home from work (it’s about 10 mins away so the warning lets me get dinner on before she gets home)

First try, it works!

A little too well.

It seems to be randomly notifying me that she’s coming home constantly. If I click on the badge for her mobile it’s been at home for hours now and hasn’t left so I’m not sure why it thinks she’s coming home.

I checked the logs and apart from it complaining one of my mqtt devices is sending bad json and that the tv is unrestable there’s nothing in there.

Perhaps someone here can point me in the right direction?

- alias: 'Clio leaving work'
  trigger:
    platform: zone
    event: leave
    zone: zone.clio_work
    entity_id: device_tracker.clio_mobile
  condition:
    condition: time
    after: '18:00'
  action:
  - service: notify.mobile_app_pixel_3_xl
    data:
      message: 'Clio is coming home'
  - service: tts.google_say
    entity_id: media_player.kitchen_speaker
    data:
      message: 'Clio is coming home'

I was pondering having it disable the automation once it triggered the first time and have a second automation that re-enables it if she arrives at work before 5pm… But maybe there’s another way?

Edit: I just pulled up the traccar logs and it turns out it’s not home assistant, she’s flying all over the place (must just be too short a time period to show up in the badge history bar) might have to see if I can combine the GPS log with some sort of check to see if her mobile phone is on the wifi (cos if it’s on the wifi she’s not leaving work)

try and increase your home zone area. Had to do this to avoid too frequent triggers and false positives too

Anyone find a cure for this issue? I will be at home and my Home Assistant will notify me of exiting every zone I have listed randomly. It’s happened at 5:00AM while I’m sound asleep the past two mornings. Making my home zone bigger won’t fix this if it’s saying I’ve exited other zones.