Errors on the total connect platform

I’m starting at homeassistant and I’m having difficulty setting up

If someone could help me I would be very grateful !!!

2017-07-25 09:04:06 INFO (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=alarm_control_panel, service=alarm_disarm, service_data=code=, entity_id=alarm_control_panel.ihouse, service_call_id=4345002360-2>
2017-07-25 09:04:06 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/asyncio/”, line 181, in _step
result = coro.throw(exc)
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/homeassistant/”, line 1023, in _event_to_service_call
yield from service_handler.func(service_call)
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/homeassistant/components/alarm_control_panel/”, line 109, in async_alarm_service_handler
yield from getattr(alarm, method)(code)
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/asyncio/”, line 331, in iter
yield self # This tells Task to wait for completion.
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/asyncio/”, line 244, in _wakeup
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/asyncio/”, line 244, in result
raise self._exception
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/concurrent/futures/”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/homeassistant/components/alarm_control_panel/”, line 84, in alarm_disarm
File “/Users/rodolfoportugal/.homeassistant/deps/total_connect_client/”, line 190, in disarm
deviceId = self.get_security_panel_device_id(location)
File “/Users/rodolfoportugal/.homeassistant/deps/total_connect_client/”, line 102, in get_security_panel_device_id
raise Exception(‘No security panel found’)
Exception: No security panel found

i got the same error. i dont know how to solve this issue

Did you load the dependencies? I’m getting the same error, but for some reason when I try to load the dependencies I get an error saying unable to locate package. Does anyone know how to resolve this?

Any news on this topic?

i give up with total connect. I go envisalink method.