ESP HOME Flashing error..unable to resolve address

I have an RPi 3b+ hardwired to a gigabit swtich connected to a nest Wifi router with 3 additional “pucks”

I have used blynk in the past successfully, but want to use ESPhome and home assistant.

When attempting upload, I am getting error that it cannot resolve the IP, and when I try to with setting a manual IP, I receive unable to route error.

Anyone else using nest wifi? I think it might be due to assigning .local domains, but I am not sure.

What firmware is on the esp at the moment?

Not positive, but I tried with a few ESPS previously flashed with BLYNK, and a brand new one out of the package with no luck…

I will verify the FW version and report back.

First time uploading you have to upload the bin file manually
once esp nows about it you can do over air update.

if you can’t over air update you mite have to put manual IP address in

If you have the ESP32 and are uploading for the first time, you may need to press boot button.

I have it plugged in via USB

tried holding the flash button, as well as tapping it,

ERROR Error resolving IP address of hallow.local. Is it connected to WiFi?
ERROR (If this error persists, please set a static IP address:
ERROR Error resolving IP address: Error resolving address with mDNS: Did not respond. Maybe the device is offline., [Errno -5] No address associated with hostname

You are trying to upload via network, whereas you neer to do it via serial. Choose the tty device in the drop down box.

I downloaded the flashing toold and got it going, except now, the flashing hangs here indefinetly:

][I][ota:046]: Boot seems successful, resetting boot loop counter.