ESP32-CAM Flashes, Boots, then eventually stops sending images

This device seems to be one of the most unstable devices I’ve attempted to implement.

or, it’s directly related to migrating from a RPi3 running to Ubuntu under Docker. Prior to running in Docker, I had no problems flashing or getting these devices to work.

  1. First problem occurs when you flash it and reset it. The voltage delivered by the USB port on the host is hit or miss and it seems that it’s required to switch to 5V power between flashing and powering it up.

  2. ESPHome uses mDNS, and despite my network setup, no green lights, even though the devices are accessible for upload. Just visual, but annoying.

  3. The camera with the default Thinker code delivers a decent image with a slow frame rate, but shortly after, (could it be a heat issue), the camera quits delivering an image despite being able to ping the device.

  4. I’ve spend more time on trying to figure this out so I can pinpoint the key points to pay attention to, but I’m thinking I’m going to ditch the cheapo cameras and just get cameras that work.

Has anyone figured out a definitive way to setup and ensure that the ESP32-CAM module fires up and remains stable, including identifying what will cause it to act up? I’ve about had it with the ESP8266 chips, as all of them seem to act up, even when connected to a stable power source.

I see the same, works long enough for me to get an image or two

I know that there’s a difference between the board settings as I’ve found that flashing a NodeMCU1.0 using nodemcuv2 can cause problems.

I wonder if I’m just not using the right board setting? No clue.

I’ve tried many board types within esphome with no luck, through esphome it only “boots” to a flashing LED. If I flash through the Arduino IDE it will actually boot and let me capture an image.

FWIW: I have

Edit: I used esphome-flasher and it works now. I’ve been banging my head on my desk for weeks over this.

Solved: ESP32-cam stops serving frames
I have the ESP32-cam now running continuously for a few days without any issues. In the past, the camera used to stop working after a few hours, though the other functions would still work (e.g. turning on the flash through GPIO)
The root cause in my case was the camera sensor getting overheated. I mounted it on a pretty large heat sink and that seems to have solved the issue.
See also:
BTW, also set the “board type” to "esp32dev "
Hope this helps anyone with the same issue