ESP32-CAM not visible when accessing HA from outside?

I have an ESP32-CAM module connected to my home assistant and now I see that when I connect to my HA from outside my home (through https & DuckDNS) the camera images are not shown.

Is this because I’m accessing HA from outside? Or because I use https and the esp32-cam is on http ?

It’s not because of this. I have http cameras working over duckDNS https.

Showing your relevant config (camera config, Lovelace camera card) might help.

I’m not home now, but I can already say that I use the picture card. Maybe that is the problem?

I’m using picture entity cards and generic camera components (not streaming).

I followed the instructions from this web page :

What do you mean by generic camera components?

I tried entering following code :

  - platform: generic
    name: cam_gang
    verify_ssl: false

Still doesn’t work, I even do not see a new card.
But HA shows that the “camera” component as an unused entity.

maybe that is the problem? Because it seems that I already tried that code and it was still in my configuration.yaml

Add your own card. E.g.

entity: camera.lounge
type: picture-entity

now you completely lost me
Where do I enter this code ? in configuration.yaml or in the configure UI -> add manual card? Do I enter this code before my “camera:” code?

The documentation of Home Assistant lacks a little bit for people who are still learning. :frowning:

sorry for asking all these questions and I’m glad that you’re trying to help

Configure UI, add a picture entity card. Paste your config there.

Also I’m pretty sure this isn’t correct:



I can’t see my camera outside my network, using DNS.

Were you able to solve your problem?

How to configure?

Hi Tom,

I have got the same issue as Steven1977. May you show me your config?

entity: camera.front
name: Driveway
show_state: false
type: picture-entity

Did anyone find a solution to this? I have same problem. Camera work fine over .local or 192.x.x.x but not over my duck DNS. Thanks.