ESP32 - Cannot update - Error 104 - Connection reset by Peer

Good afternoon all,

I saw the update about Bluetooth Proxies and decided to dip my toe in the water with a couple of ESP32s. I bought a set of three off Amazon, as recommended by @EverythingSmartHome’s video about presence detection (The BEST Smart Home Room Presence Detection I've Tried! - YouTube). I’ve followed tutorials on setting up BLE proxies and Presence Detection to the letter, including this one(How to turn an ESP32 board into a Bluetooth proxy for Home Assistant | ESPHome Bluetooth Proxies - YouTube) from @kpeyanski. For some reason, I am unable to get the same results. When the ESP32 is detected it does not pick up anything Bluetooth related. All I’m looking to control are the Switchbot curtain motors at this time. When it’s come to Presence detection I’m faced with the same issue. The ESP32 is picked up by the MQTT broker, in the device logs it’s picking up all kinds of Bluetooth devices, but nothing is picked up in Home Assistant (besides the ESP32).

ESP Home says that the devices need updating. I’ve tried to run this OTA and I get error 104 connection reset by peer (screenshot below). I’ve run this plugged into the matching running Home Assistant. Error 104 connection reset by peer. This can get to different stages before it happens - the highest I’ve seen it get to is 57%. I’ve downloaded the files and updated them manually through the ESP Home website and that appeared to work, but ESP Home in Home Assistant still said it required an update and I still don’t pick up any Bluetooth devices. I’m also unable to ‘adopt’ the devices. I just seem to go around in circles with that one and get the same error 104.

I’ve tried with all three ESP32 chips that I have and I don’t get a different result. I cannot update them and I do not get anything picked up by them in Home Assistant.

I’m running Home Assistant through a Virtual Box machine on a 2012 Mac Mini. It’s running an MQTT broker, mainly for Zigbee2MQTT but it’s also doing a couple of other bits, so I know that’s working, I’m feeling a bit stumped and I’m looking for some kind of guidance on how to get around this if anyone is able to help?



I’ve had this problem with bad power supply for ESP32 board. Try with different/better supply. It could be not powerfull enough, however it could be some cheap china switch-mode PSU who sends tons of spikes allover and disturbs correct working of ESP32.

I’ve had it plugged into the PC, Mac Mini and initially an IKEA qoppla USB multi-socket. Trying it with a Fire HD7 charger and same result, I have an iPhone charger that I can try, after that, I have a 9w one from, I think, an older model Echo Dot. Otherwise, I don’t have any further options when it comes to power supplies. Hoping it is something as simple as the plug though.

I’ve tried to rename the device twice. The first time it got to 31% before error 104, second time 57%, that’s on the Fire Tablet charger.

Ok, so the 9w charger it got to a new record of 83% before the same error! I don’t know what else to use though! Second time with it and it’s 37%, so I don’t know that it’s the power supply. Is there anything else that I can look at?

The way I’m starting to look at this is that I must have some duff chips and send them back. I have no idea about this stuff though so it would be great if I could get some pointers as it’s made to look really simple in the YouTube videos. I just find it hard to believe that all three would have exactly the same problem.

Wifi connection problems? Try to reboot your router, or see if you can change anything… some routers have “turbo mode” or similar, which can do bad to esp’s…

I confess I’ve not restarted it, but it’s been moved between two access points. I’ll give it a go and see what happens. I’m using a Unifi Dream Machine as the main router, with three Access Points. Just to add one thing that I have also done, I fixed the IP address of all three.

Similar here, only using asus aimesh. I did have “funny” connection drops, reboot of all points solved it.

1 Like

Argh! Got to 88%, then the same error104 connection reset by peer.

Can I just check, it should pick up the SwitchBot curtains via Bluetooth, shouldn’t it? I’m not going mad and trying to do something that isn’t possible with the Bluetooth Proxy?

If you still have this issue, better flash it via usb and update to the latest esphome. OTA is interrupted because bluetooth tries to rescan and disconnects the wifi.