Esp32 not connecting too the wifi when it clearly states it sees it

hello everybody. i have an issue with setting up new devices in esphome. all old devices work but if i try too use this simple code on one of my esp32 (i have tested multiple) then they dont connect too the wifi. please see code and picture below:

  name: "utomhustemp"
  board: nodemcu-32s
    type: arduino

# Enable logging
  level: VERBOSE
# Enable Home Assistant API
    key: "c0TFMnfUzmphPKhxRvcQH1l4AHKaQMEZ3kvxG8PBkAE="

  password: "988e6a9fb2e2ef158a91ec8a032c4c1a"

  ssid: KJEM5_RPT
  password: MyWifiPassOfc

i have copied the exact same credentials that work on my old devices. isnt it weird that it tells me in the logs that it indeed does see the network i specified but then proceeds too say otherwise? i dont wanna update my other devices if they would start too have the same problem. if anyone has a clue too why this is happening, please feel free too comment. (i am swedish, sorry for bad english)

Is the segment you’re trying to connect to 2.4Ghz, 5Ghz, 6Ghz (wifi6e) or mixed with band steering?

thank you for the quick reply. it is 2.4 Ghz but i have also tried 5Ghz. the weird thing is that my older devices running older firmware work flawlessley and they are litterly the same esp32s bought at the same time succesfully connecting too the same wifi i am trying too connect too

K that blows my idea - some ESPs have problems connecting to 5/6Ghz segments - but if it’s 2.4Ghz only that’s not it.

alright. thanks so much anyway

i fixed it. not sure what did it. but i used networks: bssid: bla:bla:bla:bla instead of ssid and tried flashing directly from the server

1 Like