ESP32 S3 Box3

Why yes. I’ve been doing that for the past week. Here’s the first version that has some (bad) learning built in:

And here’s the more recent version that has better learning, has four buttons, and saves to flash (it’s a WIP but at least the IR stuff works):

I’m on the ESPHome discord if you’d like to chat.

3 Likes

No voice assistant

WIP = Work In Progress. I’m starting the VA integration today. You can merge my work into your existing VA implementation if you like.

The one at firmware/wake-word-voice-assistant/esp32-s3-box-3.yaml at 7b33f69cbef2723942768c37592fde14fcde17fa · esphome/firmware · GitHub freezes up on Box 3 once or twice per day, so hopefully I can find and fix that issue as well.

Hello, you install BIGBOBBAS screensaver

anyone else having wakeword issues recently?

Edit: reported here already: on device wake word only works for first command - s3box3 wake word config · Issue #219 · esphome/firmware · GitHub

I had the same problem I had to turn off and restart homeassistant

Is there a way to set the wake word sensitivity?

Anyone else unable to compile after making changes? I’ve added a binary sensor for presence detection and attempt to install wirelessly -

substitutions:
  name: esp32-s3-box-3-5acae4
  friendly_name: ESP32 S3 Box 3 5acae4
packages:
  esphome.voice-assistant: github://esphome/firmware/wake-word-voice-assistant/esp32-s3-box-3.yaml@main
esphome:
  name: ${name}
  name_add_mac_suffix: false
  friendly_name: ${friendly_name}
api:
  encryption:
    key: <redacted>


wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

binary_sensor:
  - platform: gpio
    pin:
      number: GPIO21
    name: "Radar detect"
    disabled_by_default: true
    device_class: "occupancy"
    entity_category: diagnostic

and I keep getting an adf error when compiling. I removed the sensor and tried to compile, and I still get the same error.

INFO ESPHome 2024.6.6
INFO Reading configuration /config/esp32-s3-box-3-5acae4.yaml...
INFO Updating https://github.com/esphome/esphome.git@pull/5230/head
INFO Updating https://github.com/jesserockz/esphome-components.git@None
WARNING GPIO0 is a strapping PIN and should only be used for I/O with care.
Attaching external pullup/down resistors to strapping pins can cause unexpected failures.
See https://esphome.io/guides/faq.html#why-am-i-getting-a-warning-about-strapping-pins
INFO Generating C++ source...
INFO Updating https://github.com/jesserockz/esp32-s3-box-3-board.git@main
INFO Updating https://github.com/espressif/[email protected]
INFO Updating submodules (components/esp-sr, components/esp-adf-libs) for https://github.com/espressif/[email protected]
Traceback (most recent call last):
  File "/usr/local/bin/esphome", line 8, in <module>
    sys.exit(main())
             ^^^^^^
  File "/esphome/esphome/__main__.py", line 1079, in main
    return run_esphome(sys.argv)
           ^^^^^^^^^^^^^^^^^^^^^
  File "/esphome/esphome/__main__.py", line 1066, in run_esphome
    rc = POST_CONFIG_ACTIONS[args.command](args, config)
         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/esphome/esphome/__main__.py", line 484, in command_run
    exit_code = write_cpp(config)
                ^^^^^^^^^^^^^^^^^
  File "/esphome/esphome/__main__.py", line 194, in write_cpp
    return write_cpp_file()
           ^^^^^^^^^^^^^^^^
  File "/esphome/esphome/__main__.py", line 212, in write_cpp_file
    writer.write_cpp(code_s)
  File "/esphome/esphome/writer.py", line 344, in write_cpp
    copy_src_tree()
  File "/esphome/esphome/writer.py", line 297, in copy_src_tree
    copy_files()
  File "/esphome/esphome/components/esp32/__init__.py", line 684, in copy_files
    repo_dir, _ = git.clone_or_update(
                  ^^^^^^^^^^^^^^^^^^^^
  File "/esphome/esphome/git.py", line 111, in clone_or_update
    run_git_command(
  File "/esphome/esphome/git.py", line 31, in run_git_command
    raise cv.Invalid(lines[-1][len("fatal: ") :])
voluptuous.error.Invalid: Unable to find current revision in submodule path 'components/esp-adf-libs'

I’m running ESPHome 2024.6.6 in a Docker container on a Linux system with 32G of Ram, so I don’t believe it a memory space error I have seen mentioned in a couple of places.

Is it possible to make the voice satellite play a sound when the wake word is detected? The screen isn’t always viewable so I would like an alternate method of knowing that the speaker is listening.

1 Like