ESP32 serial port not appearing

Hi there,

Recently bought a nodeMCU esp32 and started the process of installing things via the HA addon, ESPHome. I added my device but when I go to install via “plug into this computer” I don’t see the coms port appear (using chrome on osx). I’ve tried both my OSX laptop and Windows machine and both suffer the same issue. I then tried around four different cables.

Starting to think perhaps the esp32 is a dud. How can I find out what’s going on and if the esp32 is a dud?

Help appreciated.

You are using the web based flasher? Try the stand alone. You would choose manually from the options menu and download the.bin file.

Correct, via the HA addon. Thanks, I will give this a go.

Just tried this and I can’t get my ESP to show up in the serial port dropdown - it’s just blank. Do the two buttons on the ESP do anything? I thought I read you can perform like a reset type thing.

Try another USB cable

1 Like

Turns out the USB cable was the original issue. I can now see it appearing on the device manager. The next problem is that there is an explanation mark next to the ESP named “CP2102”. I tried automatically updating the driver and this fails to find anything. I am using Windows 11 and at the moment can’t find any drivers that I can get to work. The only file I managed to download has some system catalougue files that I can’t do anything with.

Im going crazy!

I use a flesh esp addon ESPhome in HA.
On Rpi4 I connect USB to HA, I create a new node, I choose to upload via USB and it always works well.
The driver for windows are here:

I’ve got working USB cables that the ESP will show up in my device manager, but on windows 11 none of the driver packages seem to work. I am still looking for a solution. As @pepe59 stated, I could plug directly into my pi running HA but I am sure there is a way to get this working.

si tu utilises arduino et télécharges webserver dans les exemples en entrant tes identifiants WiFi tu devrais pouvoir le tester et voir si ça fonctionne non? il est bien détecté par la Livebox mais impossible de le mettre en ligne avec ESPhome!