ESP32 throws core panic at boot - tried with 2 boards

I just tried flashing my new ESP32 and its throwing an exception and halting, and I can’t see what I am doing wrong in the yaml code to cause this, does anyone know what in here I messed up to break this? I’ve tried commenting out segments to find it, like the entire stepper sequence but most of it is pretty much copy paste so I am unsure where the issue is.

Using 'COM3' as serial port.
)Writing at 0x00088000... (100 %)Wrote 897520 bytes (501499 compressed) at 0x00010000 in 44.5 seconds (effective 161.5 kbit/s)...
Hash of data verified.

Hard Resetting...
Done! Flashing is complete!

Showing logs:
[18:10:17]ets Jun  8 2016 00:22:57
[18:10:17]rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
[18:10:17]configsip: 0, SPIWP:0xee
[18:10:17]mode:DIO, clock div:2
[18:10:17]entry 0x40080310
[18:10:17][I][logger:116]: Log initialized
[18:10:17][E][Preferences.cpp:457] getBytes(): nvs_get_blob len fail: 0 NOT_FOUND
[18:10:17][C][ota:364]: There have been 0 suspected unsuccessful boot attempts.
[18:10:17][I][app:028]: Running through setup()...
[18:10:17][C][a4988.stepper:010]: Setting up A4988...
[18:10:17][E][Preferences.cpp:457] getBytes(): nvs_get_blob len fail: 1 NOT_FOUND
[18:10:17]Guru Meditation Error: Core  1 panic'ed (InstrFetchProhibited). Exception was unhandled.


  name: mini_aquarium
  platform: ESP32
  board: nodemcu-32s

  ssid: !secret AP
  password: !secret APPW

# Enable logging

# Enable Home Assistant API
  password: !secret OTA_PW

  password: !secret OTA_PW

  sda: GPIO21
  scl: GPIO22
  scan: False
  - platform: adc
    pin: A0
    name: "water_prob_v"
    unit_of_measurement: "V"
  - platform: adc
    pin: A3
    name: "bed_prob_v"
    unit_of_measurement: "V"
  - platform: bme280
      name: "MiniTank Temperature"
      oversampling: 16x
      unit_of_measurement: "°C"
      name: "MiniTank Pressure"
      unit_of_measurement: "P"
      name: "MiniTank Humidity"
      unit_of_measurement: "%"
    address: 0x77
    update_interval: 60s
  - platform: tcs34725
      name: "TCS34725 Red Channel"
      name: "TCS34725 Green Channel"
      name: "TCS34725 Blue Channel"
      name: "TCS34725 Clear Channel"
      name: "TCS34725 Illuminance"
      name: "TCS34725 Color Temperature"
    gain: 1x
    integration_time: 2.4ms
    address: 0x29
    update_interval: 60s
  - platform: homeassistant
    name: "Feeder Toggle"
    entity_id: sensor.mt_feeder_toggle
      - above: 50.0
        - stepper.report_position:
            id: feeder
            position: 0

        - stepper.set_target:
            id: feeder
            target: 0
        - stepper.set_target:
            id: feeder
            target: 1000
# Individual outputs
  - platform: ledc
    id: 'R'
    pin: GPIO8
  - platform: ledc
    id: 'G'
    pin: GPIO9
  - platform: ledc
    id: 'B'
    pin: GPIO10
  - platform: ledc
    id: 'W'
    pin: GPIO11
  - platform: ledc
    id: 'Pump'
    pin: GPIO3
  - platform: ledc
    id: 'Htr'
    frequency: 120
    pin: GPIO4
  - platform: ledc
    id: 'Air'
    frequency: 120
    pin: GPIO5
  - platform: rgbw
    name: "Tank Light"
    red: R
    green: G
    blue: B
    white: W
  - platform: monochromatic
    name: "bed_pump"
    output: 'Pump'
  - platform: monochromatic
    name: "heater"
    output: 'Htr'
  - platform: monochromatic
    name: "air_pump"
    output: 'Air'
  - platform: a4988
    id: feeder
    step_pin: GPIO0
    dir_pin: GPIO1
    max_speed: 250 steps/s
    # Optional:
    sleep_pin: GPIO2
    acceleration: inf
    deceleration: inf

I believe this is fixed in dev version. Can you try using dev version?

I switched to dev and re-compiled and tried it again, no dice.

I will play with it some more tonight, another board had some brownout issues so maybe its just a power issues.

I’ve got the same issue, but mine also keeps rebooting. I ordered another one to see if that fixes the issue. But now ordered a different board time (mini).

This comment is not very helpful, i know :wink:

OK, I have narrowed it down to using the ledc on pins 8,9,10,11 as being the issue, problem is nothing is wired to them right now so im a little confused as to whats the problem.

So just in case anyone else reads this thread with a similar issue, don’t use pins 8,9,10,11 on the MCU32 boards, it breaks it all. Once I moved the pins it started running fine.