ESP32 type C with USB C - Cannot flash with ESP Web Tools

Just bought some new ESP32 that have a Type C USB connector instead of the Micro USB that I previously used.

I just cannot seem to flash these with the ESPHome Web Tools. I tried pressing boot and reset buttons as well. It just does not want to play.

It connects ok to my windows PC with the usual windows driver.

I have tried with 2 different ESP32 that are Type C
Any suggestions?

ESP32 Development Board TYPE-C USB CH340C

I had the same issue with the lolin_s2_mini (also an ESP32 with Type C). Spent a day trying to flash it the usual way, but no luck.

Went through all the troubleshooting steps like checking the cable is actually wired for data and reinstalling new drivers, but ESPHome wouldn’t flash it no matter what I tried.

In the end, I came across a post which said that ESPHome calls some kind of reboot during the flashing process, causing it to be kicked out of boot mode. Some more digging around led me to Adafruit ESPTool, which lets you perform the first flash without any issues.

This video shows you how to do it step by step (apologies for the annoying robot voice, it was the first video I found).

So far I know - Home Assistant on Raspberry (not sure about other platforms) not supporting CH340 yet. Me flashing all boards first time connecting to Windows PC. All serial chips supported, no issues.

Try a different cable.

That’s interesting. I have about 7 of these around the house that had no issues flashing with standards methods (most were done more than once).

Some boards you can just reset the board with one button and keep the flash button pressed down to enter the flashing mode. Other boards the reset button do not seem to work, so you need to cut the power and then hold down the flash button when you connect it again.

Believe me, I tried every possible combination. I even tried chanting every spell from Harry Potter during a full moon.

Nothing would get the board to flash until I tried the Esp tool above. It flashed on the first try when I did that, no chanting required.

Well, let us just list all options.
Then the OP have to test them and see if not one of them works. :wink:

This morning I dug out a S2 for a new project and it would NOT flash on my laptop with ESPHome Webflasher. As mentioned by others I checked and changed cables, USB ports, button press combinations.

Then I tried the Adafruit ESPTool and it worked first time and is now happily residing on my network and giving me spurious data. That’s because it’s not connected to any electronics yet I hasten to add!

So for me the Adafruit is the way to go.

Maybe there have been an update of the browser that have rendered the web flasher defunct.

Thanks but mine is not a S2.
It is:
ESP32 Development Board TYPE-C USB CH340C
And I agree the video is awful

Yes tried many cables. A really good quality one as well.
The model is:
ESP32 Development Board TYPE-C USB CH340C

Is this similar to what you have?
Did you need to press any boot or flash buttons?
Normally with ESP web tools nothing is needed to be pressed.
Even thought I tried all possible combinations and with power off on etx