ESp32 Voice Assistant - Help (No microphone seemingly..)

Cool - your 2nd link is what I’m working with basically. That helps. Thanks again for all the help/response!

Tossing this into the mix:

I know all the containers are running - and I think the piper one only became available once I did a test via the HASS gui. There is a github issue opened for this - but nothing has come of it. Considering this, would this cause what I’m seeing as well?



Hello @vexter0944 ,
I have exactly the same issues as you with a similar setup. HA, OpenWakeWord, Whisper, Piper work in Helm charts on my NAS via TrueCharts. My pipeline works perfectly in debug mode from my PC, the microphone works with an ESP32-S3 and microwakeword (but still generates the same 44 octets file for Whisper as well).
Have you solved your issues? I think that voice assist is not meant to work anywhere other than on HAOS.


I unfortunately have not solved my issues. Thanks for jumping in with your results, appreciate the input. I feel like the whole voice assist is about half baked right now, so I’m going to hold off for more developments and see where it goes.

1 Like

Thank you for your feedback. I hope the issues are resolved quickly. I’m not sure how to address the problem or even participate in any way to its resolution.