ESP8266 on different vlan

Hi. Have an issue with my 8266 project. I try to config it to use my ioT vlan, called vlan17. I run Hassio on raspberry on my primary home vlan.

If I setup my esp to run on my wifi connected to same vlan as home assistant, it works fine.
I’d like to set it up on my other wifi, connected to vlan17. The firewall is set up to access both vlans from each other.
Got no connection to home assistant, but I can now upload a new config OTA, so it must have some connection. After a OTA upload I can see in the log it connects. Also I have a raspi zero that I read some gpio:s from that also is connected to my other wifi on vlan17 and this works just fine.
If I press the show logs button, it connects and I get some info about the node.

So poroblem is, I don’t get the green online indicator in the esp home dashboard, and my sensors are greyed out when configured on vlan 17. Not really sure what I miss here.
Some help to point me in right direction would be appreciated.

I figured out I can get the node show up online by enable status_use_ping in the esp home config.
It now show online, but it’s still unavailable in my integrations.

mr 'UP here did a fine job of setting up his and explaining it.
i wonder if there are any clues in there?
snooping maybe?
check this out (if you haven’t already :open_mouth: )

Are you saying the esp device is not showing up in HA at all?

You say you get the logs, what do they say?

The devices showing up in HA, but marked as unavailable. Since in my initial test I used same vlan as HA, I got it show up. Now when I change my ip to vlan17, its unavalible.

Log as follow

INFO Reading configuration...
INFO Starting log output from 10.20.17.100 using esphome API
INFO Connecting to 10.20.17.100:6053 (10.20.17.100)
INFO Successfully connected to 10.20.17.100
[08:48:09][I][app:096]: esphome version 1.13.6 compiled on Sep 17 2019, 19:28:15
[08:48:09][C][wifi:372]: WiFi:
[08:48:09][C][wifi:254]:   SSID: 

[redacted]
[08:48:09][C][wifi:255]:   IP Address: 10.20.17.100
[08:48:09][C][wifi:257]:   BSSID: 

[redacted]
[08:48:09][C][wifi:258]:   Hostname: 'test02'
[08:48:09][C][wifi:262]:   Signal strength: -77 dB ▂▄▆█
[08:48:09][C][wifi:263]:   Channel: 11
[08:48:09][C][wifi:264]:   Subnet: 255.255.255.0
[08:48:09][C][wifi:265]:   Gateway: 10.20.17.1
[08:48:09][C][wifi:266]:   DNS1: 0.0.0.0
[08:48:09][C][wifi:267]:   DNS2: 0.0.0.0
[08:48:09][C][gpio.binary_sensor:015]: GPIO Binary Sensor 'Test02'
[08:48:09][C][gpio.binary_sensor:016]:   Pin: GPIO2 (Mode: INPUT_PULLUP)
[08:48:09][C][switch.gpio:042]: GPIO Switch 'Wifi_relay'
[08:48:09][C][switch.gpio:043]:   Pin: GPIO0 (Mode: OUTPUT, INVERTED)
[08:48:09][C][switch.gpio:059]:   Restore Mode: Restore (Defaults to OFF)
[08:48:09][C][logger:137]: Logger:
[08:48:09][C][logger:138]:   Level: DEBUG
[08:48:09][C][logger:139]:   Log Baud Rate: 115200
[08:48:09][C][logger:140]:   Hardware UART: UART0
[08:48:09][C][ota:029]: Over-The-Air Updates:
[08:48:09][C][ota:030]:   Address: 10.20.17.100:8266
[08:48:09][C][api:103]: API Server:
[08:48:09][C][api:104]:   Address: 10.20.17.100:6053

Weird that your esp device doesn’t have a DNS server. Whats up with that? I guess the rest is working via mDNS?

Don’t think the DNS has any impact. Since I use static ip I assume HA try to connect to that IP since i get the logs. But HA itself seems to fail discover the node.

When it is on the other vlan (the one that works) does it get a dns server?

Don’t know, I didn’t use static ip at all when I first tried it. I just worked (gota an ip from DHCP). Not able to test changing it back right now. But Í think the issue here is related to mDNS. I use pfsense as firewall and enable it there. But maybe I need some additional configuration. It’s a bit out of my area, so not sure how to make this work.

Is it defined in HA via its ip or hostname? Take a look in /.storage/core.config_entries

1 Like

How do I access this file? Im running Hassio. Don’t have any terminal access

Install one of the ssh addons.

seems to be defined by its hostname

"host": "test02.local"

Think I manage to solve it. I removed my node from integrations, and did a new upload of esp firmware.
Was expecting it to show up in integrations again, but not.
So I added it manually by the ip and now it available again.

3 Likes

Just a quick thank you :slightly_smiling_face:
I just migrated my esphome ESPs to a new VLAN and were disabled in HA. Indeed they where defined by their IP address in the .storage/core.config_entriesfile.
After modifying the IP addresses in that file and a restart of HA, the ESPs are enabled in HA.

Thanks!

2 Likes

Just wanted to say thanks too. Another 10 months on and following a network migration I couldn’t find out why my ESPHome stuff was flashable but not showing in Lovelace as connected.