ESPHome addon does not start anymore

Setup:

  • Home Assistant 2022.9.5
  • Supervisor 2022.09.1
  • Operating System 9.0
  • Frontend 20220907.2 - latest
  • ESPHome Addon: 2022.9.0

Issue:

  • ESPHome addon does not start anymore
  • Details: in attempting to delete a duplicate discovered ESP device, I uninstalled + reinstalled the ESPHome addon several times. At this point, the addon seems to install just fine (see logs below), but it does not start anymore. When clicking the start button, nothing happens.

Steps attempted to resolve:

  • Restored full backup
  • Uninstalled ESPHome addon
  • Removed /esphome folder in /config folder
  • Removed all esphome* files in /.storage folder
  • Restarted Home Assistant
  • Reinstalled ESPHome addon => same result

Log of ESPHome addon start:

The start-up process seems to be stuck on starting NGINX…

Any help will be greatly appreciated.
Am near point of giving up.

That is where the log ends, it shows a successful start up.

Looks like a firewall block.

First try to reset defaults. go to setting/add ons/esphome/configuration/ on ESPhome the 3 dots rest to defaults, and then do same under networks.

restart HA

Update to ESPhome to 2022.9.1 and if needed try again all the resets.

No it is just where the log ends, until you open the esphome UI.

Thx for the suggestions !

Tried: reset ESPHome addon reset (3 dots), reset Networks => addon does not start
Tried: install latest ESPHome addon 2022.9.1 => addon does not start
Tried: reset 2022.9.1 reset (3 dots) + Networks reset => addon does not start

@nickrout Good to understand that this is where the log ends, but the fact remains that the Addon does not start up. The dashboard does not come up; and when clicking the ESPHome icon in the sidebar, it says the addon is not started.

@KoenChiau

Just checking you did this in this order.

1/ Uninstall ESPHome.
2/ Reboot host. go to settings/systems/hardware/3 dots and reboot host
3/ Reinstall ESPHome.

Correct. No luck.

A Restarted Home Assistant is not the same as a Reboot Host.

Thanks for your appreciated support, sir.

I did go through “Reboot Host”.

FYI: I am running HA Supervised as a VM (Debian-based) on ProxMox.
The annoying thing is that it has worked for a few times on this setup, but after a few reinstalls of the addon it no longer does. Looks like there must be some corruption with the container or container mgmt.

What does docker tell you? Does it say the container is running? Can you enter the container? Did you wait for the container to start before trying to enter the ui?

I am afraid I a bit too noob to know how I can see from within Home Assistant how to talk to Docker.
I do have installed SSH and can get to the initial terminal screen.

Thank you! Now it’s working for me - but unfortunatelly when I updated one of my device to the new version of ESPHome which is contain only 4 dallas DS18B20 sensors - it’s not working : “Scratch pad config register invalid!” - yesterday everything was fine till upgrade the ESPHome.

@Mickeyb no problem glad it help you. If you still got a problem with another ESP device then just post a new topic and someone will help you.

Got it working.

  • Removed once more ESPHome addon
  • Rebooted host
  • Re-installed ESPHome addon without starting it
  • De-activated “Protection Mode” from SSH & Web Terminal addon
  • Opened Terminal session
  • Typed “docker ps” to list running containers => ESPHome not running
  • Started ESPHome addon => worked !
  • Typed “docker ps” in Terminal => ESPHome is running !

Many thanks to all for your help and support !!!

1 Like

@KoenChiau

Nice work glad you got it working finally. You don’t give up easily do you. Well done!

:+1: :grinning: :facepunch: