ESPHome "Can not remove temporary directory"

I installed ESPHome v2023.3.0 and my ESP32’s lost contact with my wifi. I then restored the old version but my ESP32’s are still showing errors. When I tried to reinstall the yaml file to the ESP32 (in case that was part of the problem) I get the following error. I have not been able to find the temporary directory. I am using a PC with Win10 to configure the ESP32 so is the directory somewhere in the PC (I have tried searching for it without success)? Or is the directory somewhere on the Raspberry pi that is running the Home Assistant software?
Thank you for your help!

INFO Reading configuration /config/esphome/esp32-2.yaml…
INFO Generating C++ source…
INFO Compiling app…
Can not remove temporary directory /data/esp32-2/.pioenvs. Please remove it manually to avoid build issues
Processing esp32-2 (board: esp32dev; framework: arduino; platform: platformio/espressif32 @ 5.2.0)

How did you install esphome on windows?

I’ve got HA Supervisor running in Docker on a Raspberry Pi.
I can see ESPHome is running in it’s own container, so I’m wondering if it might be easier to simply delete the container and start again. Any thoughts please?

You are making no sense.