ESPHome - “ERROR Error receiving acknowledge chunk”

My ESPHome seems to be broken after the recent ESPHome update. None of my devices are working (all of them) and I cannot install anything on them. I tried to delete the build files, but it didn’t work. I get this error on every device: “ERROR Error receiving acknowledge chunk”

I went back to the previous version of the ESPHome from a backup, but it didn’t work either because I need to update each device and I get an error every time I try that. It looks like the only solution is to use a direct USB connection and this could be a problem. Is anyone else having this problem? Maybe someone has found a workaround.

I’m getting that error occasionally on devices with poor wifi signal (i.e. my soil moisture meter scattered around my garden). Moving them closer to AP for the upgrade fixes the problem for me.

Thank you for your reply, but I started having this issue just now for all my EXPHome devices with different distance from APs.

Of you guys can’t be bothered to say what versions of esphome you are using, how do you expect help.

Sorry, I meant to say that it was the latest version. There was another ESPHome release, and everything works now.

Latest is not a version. Please, next time give the version properly.