ESPHome flashed Sonoff devices no longer connect to Unifi

Today, I updated my Unifi devices as I added a WiFi 6 access point and it wouldn’t configure without the update.

Now, without exception, none of my Sonoff devices that are ESPHome flashed will connect.

All of the configs have AP set with password and the SSIDs are showing up. I don’t know what the default IP is.

How can I connect to them to OTA changes and what changes if any can I make?

Should be :point_left:

One by one would be a bit ugly so best would be just to role back your (partly “failed”) AP updates to the prior (working) version I guess :thinking:

What did you update and to which firmware? I have a UAP-AC-Lite running 6.2.41 and the connection is fine.

Do other devices connect?

Have you changed the networks? Maybe you switched to WiFi6 all the networks, without fallback? (just wildly guessing)

Thanks for the reply.

I only have one WiFi 6 AP and some of the devices can’t even reach that.

These are the versions I currently have.

Screenshot 2022-11-02 at 07.35.51

Do your other devices (phone, …) connect as before?
When you say

do you mean the Sonoff devices, or the others?

Have you tried having a Sonoff connect to the UAP - I have a similar one and it works for everything (I envy your setup :slight_smile: I live with one AP but would love to have a bunch everywhere)

did you by any chance disable 2.4ghz wifi?

2.4 is on.

I replaced all of my Sonoff lightswitches today with Athom ESPHome switches, which all work fine.

I tried reflashing the Sonoff switches with recompiled ESPhome bins. Watching the logs, they all flash fine but just can’t connect to WiFi. the logs show all networks being detected and they create their own hotspots and I can connect to the hotspot but can’t access the page.

It’s a real mystery.

As far as I can see, there’s no option to turn off WiFi 6 (if that is the problem).

All other devices, wired and wireless connect as normal.

ESP32 and ESP8266 devices that I have made all connect fine. It’s just the Sonoffs and a couple of Shellys.

I have 9 UAP pros and just the one WiFi6 AP.

It all started to go wrong when I tried to add the WiFi 6 AP and couldn’t. I updated the firmware on all Unifi devices and added the WiFi 6 AP. Then all of my Sonoffs (and a couple of Shellys) dropped off the network and won’t reconnect.

I had a very similar situation: `web_server` bricks Sonoff Basic · Issue #3747 · esphome/issues · GitHub

The solution was to reduce the TX power in ESPHome (details in the issue above) and this miraculously fixed the issue of not connecting to the WiFi and the same instable captive portal.

Thank you, I’ll give that a try.

But why? What changed to break it?

That’s the bit I need to understand.

This can be the hard part (if this is the same problem as mine). I had this happening first suddenly between two ESPHome versions where the WiFi part was not changed in ESPHome code. I have no idea what caused the change.

In your case, since you upgraded the firmware of the APs there may have been a change in the AP’s power transmission (or anything else) and suddenly ESPHome did not like it anymore. That would be the technical explanation :slight_smile:

and RX a little bit too maybe? :wink:

Guess quickest try would be to give power_save_mode: set to high under wifi: a chance and see how it behaves. :pinching_hand: