ESPHome flasher cannot run

Hello all,
Have a question. I was not able to use ESPHome hassio app as it cannot find my usb port (tried all ports and different usb cables). Please note that everything works with Arduine IDE, I was able to add libraries and add example of FastLED to nodemcu and run everything on my LED strip. So went with ESPHome flasher process, but for some reason it does nothing when I run ESPFlasher on normal and on administrator. Nothing happens, the only way how to run that .exe file is with run with graphic processor which is weird. But then I get error that PORT access is denied and I cannot flash ESPHome… I am lost. Using windows 10

When I run my Flasher
I see this

then I plug in the thing im going to flash
run it again

now I see the USB port it on MY CASE COM5
click the 3dots and Compile it

download the BINARY file

the bin file should be in your download folder

1 select the port
2 click the Browse
3 click the download folder
4 find the bin file
5 open it
6 Flash it

and pray

some time you have to put gpio0 to ground when powdeing up up

hope this helps

but how you run flasher application? Just open it? As for me it is not opening only when run with graphics card.

When I start flashing it just instantly shows as PORT access denied in the logs…

so I just managed to proceed with flashing with OTA but still stuck on the same issue, so this is not the port issue… Can someone help?