ESPhome freezes during compile

Hi @OttoWinter, Ive been using ESPhome for a while now and all seems ok, but I have just tried to compile a new file and it keeps freezing. Im using v1.12.1 on hassio 0.90.2.

the file is:

  name: tempflash
  platform: ESP8266
  board: esp8285

  ssid: "homewifi"
  password: "routerap"

# Enable logging

  port: 80

# Enable Home Assistant API
  password: 'pasword123'

  password: 'pasword'

Thank you.

Are you sure it’s not just compiling?

I leave it for about 5 minutes, I then hit the stop button and return to hassio to find its not working and the pi is frozen with the green led flickering very fast and no response. I have to power cycle and start again.

The compile never use to take this time, I suppose I could leave it running for longer to see if it final compiles, just wondering if others have had issues.

1 Like

Try a make clean.

Just restarted hassio and tried after a make clean in ESPhome and it froze again. I know its frozen because I can no longer log into my unifi controller from my phone. All I can do is pull the power and restart which I hate doing, it only seems to damage the hassio database file which I delete and all seems good again.

Is you unifi controller on your pi? If not, it is irrelevant.

Also, there is a new version of esphome out, 1.12.2.

Unifi is on the pi, its a add-on in hassio which is how I know the hassio has crashed out because I can’t access anything on it after trying to compile.

Ill update ESPhome and see how that goes, didn’t realise there was a newer version

Thanks for your help

Just updated and its still freezing during compile, its so annoying, it was working so well, and it still does, its just the compiling stage.

I did try and leave a issue on there but its keeps saying:

This issue was auto-closed because the issue template was not filled out.

I can’t see where to create or fill in a template. I have logged in with an account.

The issues are lodged at this address (as per my last post, not the earlier one pointing to the new release!)

The template is obvious once you click “new issue”.

denver: It’s a capacity issue, a Pi (even a 3B+) has a finate amount of memory to run the quite heavy unifi and do a compilation at the same time. Just turn off your Unifi Controller, compile your code and then turn back on Unifi Controller… (Unfortunately HASSIO doesn’t have a huge amount of swap, and Raspberry PIs don’t have a huge amount of memory).


Meant to add, thanks for the original post, because without it i wouldn’t have realised that A) someone else runs the same configs I do and B) that it was a resource issue.

Thanks for your reply, your spot on because I’ve now upgraded to a NUC and have no problems at all.

1 Like

could you, please, share what NUC are you working with?
I have the same issue as you had…

Sure, I have the NUC8i5BEH and am running hassio inside proxmox on it. Haven’t used ESPhome for a while now but will be getting back into ESPhome.

It was the lack of power in the raspberry pi that was causing my problems, once I moved over to the NUC, I had no more issues on that front.

Thanks for the quick reply!

Obviously my problem is, also, lack of power as I am running HASSIO on an orange pi zero what it really amaze me as it is working OK, at least while working with few stuff (I am just stating on HASSIO).
I wonder how it will be on a raspberry pi 4 with 4GB RAM…

I like this raspberry like pcs as the power consumption keeps reasonable. (I like to consider power consumption being a bit more environment friendly…… Or at least less contaminating…)

Im sure it would be ok on the RPi4, I was using the RPi3 and everything work until I tried to compile the source code in ESPhome, The RPi3 just locked up and needed rebooting.

So how far through the compile did it get?

I have the similar issue. After I press compile in home assistant rpi3b freezes. But then after reboot, I can compile normally. This happens everytime I start to compile for the first time…

1 Like