ESPHOME refuses static IP Address

I have added ESPHome Bluetooth Proxy. I get iBeacon Tracker and everything works. HA, asked me to install ESPhome, and I did, when I add the ESP32 to ESPHome wipes my device and the ESP32 drops off of Wi-Fi. Looking at the logs, it says DNS Name is not found. Restart the process, this time add the IP to the YAML file (I keep the Device name the same so Yaml does not change.) Same thing happens, look into the Yaml ESPHome removes the IP, WTF? is ESP32 Bluetooth proxy a half baked attempt to add Blue Tooth to HA? or is the ESPHome addon just not ready yet for bluetooth?

looking more in to the logs I see

substitutions:
name: esp32-bluetooth-proxy-9e45e8
wifi_ap_password: ‘’’ ‘’’ <— I see this 2x

but then down the log I see the password with the correct Password.

wifi:
ap:
password: ’ ’
ap_timeout: 1min
domain: .local
reboot_timeout: 15min
power_save_mode: LIGHT
fast_connect: false
networks:

  • ssid: Something_IOT
    password: MyPassword
    priority: 0.0
    use_address: esp32-bluetooth-proxy-9e45e8.local ← again not what I want to see, but I have this in the DNS

Which I DO NOT Want to see. I want to see the IP Address.

I think none of those is true. People (including me) running esphome ble proxies without any problems. Guess most of the users don’t bother about static IP’s (why should one waste time with this if there is DHCP?).

Are you aware that devices always have a IP address and that a hostname is something different?

I expect you didn’t yet read the esphome docs?

Also additional tip if you want to “see” a IP address:

BTW: One of the ideas of esphome (together with HA) is to completely avoid wasting valuable time with IP management but rather (best case scenario) just have things automagically discovered thank’s to mDNS :raised_hands:

And another one for you @nhaas

Special attention to: :one::one: Format it properly

1 Like

Thanks for the reply, I updated ESPHome to 11.3 from 11.2. Now I can connect via IP - I dont know what the issue was, I had restarted HA several times. I have these on my IOT lan, there is NO DHCP, sorry, just security minded I guess. My other lans have DHCP, I guess I should try them on there - But I now have the Proxy working on IP directly. none of that fancy DHCP on IOT…

After updating ESPhome, I now get more lines in my Yaml. strange…

esp32:
board: esp32dev
framework:
type: arduino

Enable logging

logger:

Enable Home Assistant API

api:
ota:

I can now get the boards into ESPHome. Though I have one working and the other is not.

I will post back what my status is.

I’m quite confident the problem lies within your network configuration and HA/ESPHome are not to blame as they essential have nothing to do with your static IP management but typically human failures (wrong configurations) are mostly the root cause from my 30+ years experience in that field.

I think you there is a misconception there. Having no DHCP server doesn’t increase the security of a network - or in other words: One actually needs to breach a network (wired or wireless) to even be able to fiddle with your DHCP server. And at that state everything is lost/breached already.

Kind of the same misconception exists regarding MAC whitelisting. It is just nothing that can stop an attacker or script kiddie as the first thing ones usual does is to clone their own MAC address to an existing device solely to fly under the radar and don’t expose it’s own MAC.

Are you aware how esphome works?

Maybe take 10 minutes and get yourself comfortable how esphome actually works. The official site holds lots of useful information. :+1:

Like the FAQ which tells you about static IP’s, mDNS, DHCP and more :rocket: