ESPHome S20 set-up error connecting port 6053 (errno 111)

Hi - I have added the ESPHome add-on and configured one Sonoff S20 socket. Started ESPHome and restarted Home Assistant.

  1. wineglassled.yaml is valid but shows up as “offline” (it is plugged in and connected to my wifi successfully)

  2. “SHOW LOGS” shows an error
    INFO Connecting to 192.168.1.200:6053 (192.168.1.200)
    WARNING Initial connection failed. The ESP might not be connected to WiFi yet (Error connecting to 192.168.1.200: [Errno 111] Connection refused). Re-Trying in 1 seconds

  3. Using a web browser I can connect to 192.168.1.200 and get the basic web page but I can’t connect to 192.168.1.200:6053

Possibly nearly there so any help would be much appreciated - many thanks

****** wineglassled.yaml *******************
esphome:
name: wineglassled
platform: ESP8266
board: esp01_1m

wifi:
ssid: “couch-w”
password: “49144ebf43”

Optional manual IP

manual_ip:
static_ip: 192.168.1.200
gateway: 192.168.1.1
subnet: 255.255.255.0

Enable logging

logger:

Enable Home Assistant API

api:

ota:

*********** Versions running **************
Add-on version: 1.13.6
You are running the latest version of this add-on.
System: HassOS 2.12 (armv7 / raspberrypi2)
Home Assistant version: 0.96.2
Supervisor version: 170