ESPhome sensors sending data but unavailable

Hi! Has anyone had a situation when esp board is online, can output data in logscreen, but still all sensors show up as unavailable in dashboard and entities section in settings?

It happened after wifi network settings were changed, tried updating to esphome to 2022.6.3
Tried dashboard UI or YAML configured - no difference.

Since I have two esp32 devices after changing back to hotspot I noticed that other one is available and the one that was not available now is. That made me think about the order in which I installed them.
I guess it’s because I updated them separately? After another wireless install the missing one also got available.
So should I always use “update all” when changing wifi settings for multiple devices? Would that work on first attempt?

Hi There Karlis,

Did you have any further issues with this?
I have the same thing goimg on but I don’t understand the point you’re making

I have 5 Air Quatlity Sensors throughout the house. All of them are the same with the same config file (diff values of course) For months I have been separately updating without any issues and now all of a sudden one AQS is not showing in HA while the log file is outputting data.