ESPHome Set Up Help


I am having issues trying to get ESPhome working.
In case it is important, I previously used this ESP to run ESPresense

I first tried running the ESPhome add-on and everything worked fine until I realized that my Pi3 didn’t have enough power to compile the code which resulted in constant errors. I forgot which error it was specifically.

I then got the dashboard to run locally on my computer however, this took a few days. Once I got it running I was unable to connect to my esphome node via its IP address. I then re-installed the firmware via the local dashboard. At this point I was able to update the ESPhome node while it was plugged in (progress!) but the local dashboard and HA both said that it was offline (false). I gave the node a static IP which did not help. see ESPHome device shows offline but connected when I check my router

I figured that my next step would be to use a mix of the HA add-on (to update the node) and the local dashboard to compile. I reapplied the firmware using the ESP Web interface, and I was able to get HA to notice the node and add it as a device. But neither the add-on or local dashboard can recognize the device and HA says that it is disconnected. I am unable to update it as when I upload a bin via its local address as I get the following error:

13:37:55	[W]	[web_server_base:037]	
OTA Update failed! Error: Wrong Magic Byte

Even though the local dashboard doesn’t recognize the node currently it still has a previous configuration showing (offline). I thought that I would be able to install the update through this since the node is connected directly to my computer however when try “plug into this computer” I am able to select the port but I get the error:

Failed to initialize. Try resetting your device or holding the BOOT button while selecting your serial port until it starts preparing the installation.

When I try to install the update through the Plug into the computer running ESPHome Dashboard the correct port is selectable yet I get the following error:

ERROR Running command failed: Could not open COM5, the port doesn't exist
ERROR Please try running --before default_reset --after hard_reset --baud 460800 --port COM5 --chip esp32 write_flash -z --flash_size detect 0x10000 

HA views node as offline
HA add-on and Local Dashboard don’t recognize the device
Unable to update via local address

Any help would be much appreciated!

In the addon configuration

status_use_ping: true

Thank you for the quick response, I forgot to mention that I already have that on but it didn’t help