ESPhome won't start

I’m having an issue where ESPhome won’t start, even after repeated tries. I’ve already tried uninstalling/reinstalling, but it didn’t change anything. I’m not getting any logs on the ESPhome page, and all I get in the supervisor is

21-03-24 03:11:42 ERROR (SyncWorker_1) [supervisor.docker] Image esphome/esphome-hassio-armv7 not exists for addon_15ef4d2f_esphome

My setup:
ESPhome version 1.16.2, running on Raspberry Pi 3B+, Home Assistant OS version 5.12, Supervisor: supervisor-2021.03.6 , Core: core-2021.3.2

Have you restarted the Pi and tried again ? I had a similar issue earlier this week with another Addon that was fixed after a reboot.

I have tried restarting a few times, no help.

You can install portainer from the add-on store to check and see if it’s actually being removed when you delete it.

Will try that tonight. Is there any special way to back up my data? I think I have a copy of all the configs for my devices, but just in case I’ve changed anything in them since the last time I backed up?

Go to the supervisor page —> snapshots --> full snapshot. This has been acting up for some, myself included. It will start the snapshot then give a message shortly after that it failed.

If you try to make another you will get a message “the system is in a freeze state”. Hang in there give it another 1/2 hour or so then refresh the snapshot page, a new full snapshot should be there.

Couldn’t figure out how to use portainer (probably because I’m using hassos, not docker), but I did make another snapshot. Now, however, it wont reinstall at all, seems that it can’t find the repository?

21-03-25 01:18:26 INFO (MainThread) [supervisor.addons] Creating Home Assistant add-on data folder /data/addons/data/15ef4d2f_esphome
21-03-25 01:18:26 INFO (SyncWorker_4) [supervisor.docker.interface] Downloading docker image esphome/esphome-hassio-armv7 with tag 1.16.2.
21-03-25 01:20:14 ERROR (SyncWorker_4) [supervisor.docker.interface] Can't install esphome/esphome-hassio-armv7:1.16.2 -> 404 Client Error for http+docker://localhost/v1.40/images/esphome/esphome-hassio-armv7:1.16.2/json: Not Found ("no such image: esphome/esphome-hassio-armv7:1.16.2: No such image: esphome/esphome-hassio-armv7:1.16.2").

Update: It seems that manually restarting the supervisor, then the core, and then reloading the repositories in the add-on store did the trick. For some reason, restarting the whole pi did not work, but after individually restarting things the add-on was able to install and open no problem! I’m guessing that the path for the repository for the hassio version of ESPhome changed at some point, but my setup didn’t get that and broke it when it the last update came out. Thank you all for your help!

It may not have been completely removed. Restarting in the supervisor panel is different then the server restart on the configuration page.

Just noticed the same error on my RPi4 today, with ESPHome “failed to load add-on” error when I tried to access dashboard. ESPHome v2021.8.2.

21-09-06 17:40:38 ERROR (MainThread) [supervisor.utils.json] Can't write /data/addons/data/a0d7b954_esphome/options.json: [Errno 2] No such file or directory: '/data/addons/data/a0d7b954_esphome/tmp0vfgs3ft'
21-09-06 17:40:38 ERROR (MainThread) [supervisor.addons.addon] Add-on a0d7b954_esphome can't write options

Rebooting RPi didn’t help, but uninstalling & re-installing ESPHome seems to have resolved.

I had the same issue after updating hassio (core-2021.10.5, supervisor-2021.10.0, Home Assistant OS 6.5). Sensors were still reporting data etc, but the ESPHome integration itself refused to start, traced back to a write error. Tried all sorts of things, but the fix was (after backups up the esphome directory just in case - turned out not to matter, but good to be safe) uninstalling the integration, restarting the server, then reinstalling esphome. Everything came back as it was before.