Esphomelib and WIFI connection


i know it has already been discussed probably here and in other places.
Few references below:

Sonoff Device not connecting to WiFi

Unstable MQTT connection

Esphomelib arduino framework versions

ESPhomelib FAQs

But still…my 2 sonoff basics and Sonoff S20 keeps disconnecting very frequently.
They were reasonable once flashed with 1.8.2 version, then upgrade to latest platformIO (3.6.2) and latest Esphomelib (1.9.3) flashed and…situation is now similar to pre 1.8 version.

I followed the above suggestion but:

  • setting “arduino_version: latest” esphomelib complains “it is not a valid option for esphomeyaml”
  name: xxxx
  platform: ESP8266
  board: esp01_1m
  board_flash_mode: dout
  arduino_version: latest


  • setting “power_save_mode: light” esphomelib complains “it is not a valid option for wifi”
  ssid: 'myssid'
  password: 'mypass'
  power_save_mode: light

so I am a bit stuck in trying.
Also I see people reporting having solved the issue using a specific arduino framework version although I did not understand which one is suggested to mitigate the issue.

@OttoWinter can you be so kind to provide some advice? :slight_smile:

I suspect you’re using esphomelib v1.7.x or something even before that. Maybe that could have been caused by a virtualenv issue?

You can check which version of esphomeyaml you’re using with esphomeyaml <YAML_FILE> version - if that shows an issue you’re using an ancient version of esphomeyaml :wink:

hi @OttoWinter,

i think you made it.
So if i run:

esphomeyaml <YAML_FILE> version

i get 1.7.0 (DAMN!!!), while if i run

sudo esphomeyaml <YAML_FILE> version

i get 1.9.3 :frowning:

it is not clear to me how can I have 2 different install though…sorry for the fuss