ESPresense, android, HA companion app

Hi everyone, i just starter playing with some esp32 and ESPresense for room Level detection and…

Well, for the first time everything worked out just right!
Tomorrow I’ll try with a couple of iPhones and their irk-thing.

I still have a couple of questions though; i swear i Read the documentation and i couldn’t figure out the answers.

  1. i tried, with my android phone, both the HA app ibeacon sensor and The beacon simulator app.
    Both work well (beacon simulator a bit more responsive), but i still don’t get what causes both app to stop sending beacons.
    Sometimes the position doesn’t update, even of the app is in the foreground, sometimes it updates with the app in the background without any issue.
    What settings should i fiddle with?

2)in mqttexplorer i can see the the estimated distance of the sensor from the esp; this information doesn’t show up on home assistant. Ism’t it supposed to? I don’t really need this information, but it’s Fun.

It’s my first time with mqtt, so please be kind :joy:

Thanks everyone!

on android make sure the app has proper permission to run in teh background, some manufacturers may add additional power saving settings that you need to look for to disable as well.

1 Like

So that might be the case with ha companion app too, right?

I’d like to avoid to install another app if it’s not needed.

yes that was what i was referring to, you will need to look into device settings and see what you need to disable. In the app we have a check in Settings > Companion App then look at the background access tile and make sure its granted. This does not take into account any additional manufacturer power saving features that my have been added, this only shows what android knows.

Thank you!

1 Like

Can you please share your sensor Configuration with your Android device. In Homeassistant compaign app on my Android phone i Get a UUID when i looking under sensors. I try to set the ID in a sensor Configuration as here, but it dosent work

  • platform: mqtt_room
    device_id: “125c791a-1206-4e0e-a815-cb1309ff8987”
    name: ‘tina espresense’
    state_topic: ‘espresense/rooms’
    timeout: 10
    away_timeout: 120

Try this state topic. So far it’s working for me.

- platform: "mqtt_room"
  device_id: "iBeacon:<YOUR-BEACON #>"
  state_topic: "espresense/devices/iBeacon:iBeacon:<YOUR-BEACON #>"
  name: "Beacon Scope App"
  unique_id: "sensor.beacon_scope_app"
  timeout: 30
  away_timeout: 9