ESPSomfyRTS onboarding

Hi there (especially rstrouse :slight_smile:),

ESPSomfyRTS is a tour de force. I am astonished at the amount of work in this thing. If Somfy aren’t sponsoring this project they should be ashamed of themselves. Thank you so much for all your work on this.

I have some observations from my experience, and wondered if anyone shared them / had any thoughts:

  • Repeat: I wasn’t able to get the blinds to respond unless I had just moved them with the Somfy remote. This seemed odd because the wiki suggests that SomfyRTS should have much more oomph than the official remotes but what I was experiencing seemed to be the opposite. I ended up setting the repeat number to 2 and it now seems to work great.

  • The meaning of “open”: My blinds are venetian slat blinds and the only motorised element is the tilt. ESPSomfy (and Home assistant) regard “Open” as meaning tilted to one limit, and “Closed” as tilted to the other limit. In practical terms that means that “actually open” is 50%. In my case I tilt them up to close them as it gives more privacy, so for me 60% is the sweet spot for “open” and “open” is the correct setting for “closed”. Which is confusing.

  • 500 errors: When using the web UI, I often run into sudden “500 internal server error” screens and then on refresh find that the device is no longer online, though it comes back quite quickly. I’m using an ESP32 CP2102 variant which looks exactly like the one in the wiki.

Thanks for the compliments!!!

Repeat: The signal is much stronger from the ESPSomfy RTS however, it is very hard to get a single frame when you press a button on a remote. Very often you will get 2 or 3 frames sent out. Also, if this is a battery operated blind it is not uncommon for the motor to go to sleep between commands. Also please make sure you have not set your TX power higher than 10 if you are using an E07-M1101D transceiver. While it will accept the setting it is beyond the capabilities of the transmit power.

The meaning of “open”: Well you and I both have an issue with how HA handles this. If you have set this to a tilt type of Tilt Only the plugin will do its best to reflect closed at 0% or 100% and opening or closing at points in between. Unfortunately, controlling the cover component internal to HA beyond that is not possible as it disables the controls on either endpoint. In the end I succumbed to the pressure and conformed as this is also the same weirdness in Homekit.

500 errors: You are likely experiencing the shortcomings of mDNS on ESP32 if you are not accessing the web interface with the IP address. If you look at the browser console you will see unable to resolve host error. If you haven’t already make an IP reservation in your router for the ESP32 with the host name. This often fixes the issue with mDNS on the local network depending on your router. Also, if you are using apple products it often tries outside DNS first if you do not use the .local suffix.

That’s exactly the issue I have with the errors. I just set up an address reservation on my router so hopefully that will fix it.

I have some roller blinds to add tomorrow and I’ve 3D printed the case for it, just need to tidy the wires.

Do you accept PRs to your wiki/docs?

Of course. I can use all the help I can get.

OK, becoming ambitious, I unplugged everything and spent 2 hours soldering the radio to the ESP using a proto board, and 3D printed the case. The ESP came back, and … the blinds don’t move anymore :sob:

However! I do see entries in the radio log if I press buttons on the somfy remotes, and I can link a remote to an existing shade. Could I have messed up the TX but RX is still working?

In your configuration set the tx pin to the same as the RX and see if it comes alive.

EDIT: if it doesn’t come alive trace the connection between GDO0 and the pin selected for TX.

It works! And I’m still seeing data logged, so it’s receiving as well as sending. Would never have considered that that would work :joy:. Is there any problem with leaving it configured like this?

No issues leaving it like that since a the ESPSomfy RTS multiplexes on the GDO0 pin when it is set up like that and the Transceiver always receives on GDO0 and GDO2 but transmits only on GDO0.

1 Like